Bug 1413040 - The upgrade script uses bad credential to access to DB
Summary: The upgrade script uses bad credential to access to DB
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 580
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: Gennadii Altukhov
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat580-upgrades
TreeView+ depends on / blocked
 
Reported: 2017-01-13 13:02 UTC by Martin Korbel
Modified: 2017-01-31 12:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-25 09:06:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Korbel 2017-01-13 13:02:19 UTC
Description of problem:
Upgrade Sat5.7 exPG -> Sat5.8 exPG
During upgrading we get this error message. In this error we can see the script uses bad credential in the first trying (dbname=rhnschema','rhnuser', ...).
After that it wants to fill new credential, but as default it offers the correct credential (spaceschema, spaceuser, ...).

** Database: Setting up database connection for PostgreSQL backend.
Could not connect to the database.  Your connection information may be incorrect.  Error: DBI connect('dbname=rhnschema','rhnuser',...) failed: nelze navazat spojeni se serverem: Adresar nebo soubor neexistuje
	Je spusten server lokalne a akceptuje
	spojeni pomoci Unix soketu "/tmp/.s.PGSQL.5432"? at /usr/share/perl5/vendor_perl/Spacewalk/Setup.pm line 1707
Hostname (leave empty for local)? dbserver
Port [5432]? 
Database [spaceschema]? 
Username [spaceuser]? 
Password [******]? 



Version-Release number of selected component (if applicable):
Satellite-5.8-RHEL-6-20170112.n.0

How reproducible:
100%

Steps to Reproduce:
1. Upgrade satellite from 5.7 -> 5.8 exPG.

Comment 1 Gennadii Altukhov 2017-01-24 15:04:12 UTC
Ok, the problem is the installation script install.pl knows DB credentials but still ask them from a user. But this is not a regression as I know, so need info from Tomas Lestach.


Note You need to log in before you can comment on or make changes to this bug.