Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1413078 - Deprecation warning about BaseException.message in a log
Summary: Deprecation warning about BaseException.message in a log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mom
Version: 4.0.3
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-4.0.7
: ---
Assignee: Martin Sivák
QA Contact: Artyom
URL:
Whiteboard:
Depends On: 1370081
Blocks: 1425219
TreeView+ depends on / blocked
 
Reported: 2017-01-13 15:02 UTC by vaibhav
Modified: 2021-03-11 15:43 UTC (History)
17 users (show)

Fixed In Version: mom-0.5.9-1
Doc Type: Bug Fix
Doc Text:
This update removes a deprecation warning about BaseException.message from the log file.
Clone Of: 1370081
Environment:
Last Closed: 2017-03-16 15:41:27 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0551 0 normal SHIPPED_LIVE MOM bugfix update 2017-03-16 19:27:18 UTC

Description vaibhav 2017-01-13 15:02:32 UTC
+++ This bug was initially created as a clone of Bug #1370081 +++

Description of problem:

i get every minute a message in var log messages:

momd: /usr/lib/python2.7/site-packages/mom/Collectors/GuestMemory.py:52: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
momd: self.stats_error('getVmMemoryStats(): %s' % e.message)

Version-Release number of selected component (if applicable):

oVirt Engine Version: 4.0.2.7-1.el7.centos

How reproducible:

Always

Reported by:

Wolfgang Bucher <wolfgang.bucher@netland-mn.de> using the ovirt mailing lists

--- Additional comment from Michal Skrivanek on 2016-11-10 06:37:15 EST ---

I'm requesting .z fix since it's annoying/useless and spams system logs as well(not just mom.log), increasing size, potentially affecting performance on super-busy systems

Comment 13 Artyom 2017-02-28 11:27:09 UTC
Verified on mom-0.5.9-1.el7ev.noarch

System runs with the new mom package more than one day, no DeprecationWarning: BaseException.message under the messages

Comment 16 errata-xmlrpc 2017-03-16 15:41:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0551.html


Note You need to log in before you can comment on or make changes to this bug.