Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1413111 - remove qemu-kvm-tools-rhev package dependency for realtime-virtual-guest profile
remove qemu-kvm-tools-rhev package dependency for realtime-virtual-guest profile
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jaroslav Škarvada
Tereza Cerna
: Patch, Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-13 11:43 EST by Jeff Nelson
Modified: 2017-08-01 08:32 EDT (History)
10 users (show)

See Also:
Fixed In Version: tuned-2.8.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 08:32:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2102 normal SHIPPED_LIVE tuned bug fix and enhancement update 2017-08-01 12:07:33 EDT

  None (edit)
Description Jeff Nelson 2017-01-13 11:43:29 EST
Description of problem:
The package tuned-profiles-nfv contains the profile definitions for realtime-virtual-host and realtime-virtual-guest. This package has a dependency on qemu-kvm-tools-rhev. The reason for this dependency is so ensure the image named tscdeadline_latency.flat (in /usr/share/qemu-kvm) is installed. This image is needed to set up the profile called realtime-virtual-host.

The tscdeadline_latency.flat image is not needed to set up the realtime-virtual-guest profile, but--because the dependency exists--the guest must also install qemu-kvm-tools-rhev.

This is problematic for our customers, because it requires them to install an unnecessary package in the guest. It's problematic for some internal processes as well.

Please split tuned-profiles-nfv into host- and guest-specific packages; the dependency on qemu-kvm-tools-rhev should only be on the package containing the realtime-virtual-host profile.

Version-Release number of selected component (if applicable):
tuned-profiles-nfv-2.7.1-3.el7_3.1.noarch


How reproducible:
Install tuned-profiles-nfv

Steps to Reproduce:
1. yum install tuned-profiles-nfv

Actual results:
qemu-kvm-tools-rhev is also installed.

Expected results:
qemu-kvm-tools-rhev is a dependency only for the realtime-virtual-host profile. It is not a dependency for the realtime-virtual-guest profile.

Additional info:
Comment 1 Jaroslav Škarvada 2017-03-30 05:13:14 EDT
I am going to resolve it the following way:
- add tuned-profiles-nfv-host and tuned-profiles-nfv-guest packages
- keep tuned-profiles-nfv package which will only require tuned-profiles-nfv-host and tuned-profiles-nfv-guest for backward compatibility
Comment 2 Jaroslav Škarvada 2017-03-30 05:55:07 EDT
Upstream commit fixing the problem:
https://github.com/redhat-performance/tuned/commit/10265459360ec26e5cfdfa6a610ace52450bb2f9
Comment 4 Tereza Cerna 2017-04-11 08:21:19 EDT
============================
Verified in:
    tuned-2.8.0-1.el7.noarch
PASS
============================

1] If I want only profile realtime-virtual-guest, I can install only tuned-profiles-nfv-guest package without any dependency.

  # yum install tuned-profiles-nfv-guest
  ...
  Installing:
   tuned-profiles-nfv-guest   noarch   2.8.0-1.el7    /tuned-profiles-nfv-guest-2.8.0-1.el7.noarch   2.4 k
  ...


2] If I want profile realtime-virtual-host, it needs also missing dependency qemu-kvm-tools-rhev

  # yum install tuned-profiles-nfv-host
  ...
  Installing:
   tuned-profiles-nfv-host noarch 2.8.0-1.el7            /tuned-profiles-nfv-host-2.8.0-1.el7.noarch 6.3 k
  Installing for dependencies:
   qemu-kvm-tools-rhev     x86_64 10:2.6.0-28.el7_3.6    rhel-7-server-rhev-mgmt-agent-rpms          291 k
  ...


3] If I want to install an old package tuned-profiles-nfv, it installs also packages tuned-profiles-nfv-{guest,host} profiles and missing dependency qemu-kvm-tools-rhev. Package tuned-profiles-nfv still exists because of backward compatibility.

  # yum install tuned-profiles-nfv
  ...
  Installing:
   tuned-profiles-nfv       noarch 2.8.0-1.el7          /tuned-profiles-nfv-2.8.0-1.el7.noarch       279  
  Installing for dependencies:
   tuned-profiles-nfv-guest noarch 2.8.0-1.el7          /tuned-profiles-nfv-guest-2.8.0-1.el7.noarch 2.4 k
   tuned-profiles-nfv-host  noarch 2.8.0-1.el7          /tuned-profiles-nfv-host-2.8.0-1.el7.noarch  6.3 k
   qemu-kvm-tools-rhev      x86_64 10:2.6.0-28.el7_3.6  rhel-7-server-rhev-mgmt-agent-rpms           291 k
  ...


Tested in:
  # rpm -q tuned qemu-kvm-tools-rhev
  tuned-2.8.0-1.el7.noarch
  qemu-kvm-tools-rhev-2.6.0-28.el7_3.6.x86_64
Comment 5 errata-xmlrpc 2017-08-01 08:32:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2102

Note You need to log in before you can comment on or make changes to this bug.