Bug 1413155 - [RFE] Include disk space check in foreman-debug
Summary: [RFE] Include disk space check in foreman-debug
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Foreman Debug   
(Show other bugs)
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: 6.2
Assignee: Chris Roberts
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: FutureFeature, Triaged, UserExperience
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker 1417129
TreeView+ depends on / blocked
 
Reported: 2017-01-13 18:37 UTC by Xixi
Modified: 2018-12-06 20:45 UTC (History)
6 users (show)

Fixed In Version: katello-3.0.0-17
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1417129 (view as bug list)
Environment:
Last Closed: 2017-03-06 08:37:07 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0447 normal SHIPPED_LIVE Satellite 6.2.8 Async Bug Release 2017-03-06 13:23:41 UTC
Foreman Issue Tracker 18075 None None None 2017-01-13 20:01 UTC

Description Xixi 2017-01-13 18:37:09 UTC
Description of problem:
A basic check in troubleshooting Satellite 6 (and in deed health of Satellite) is available disk space.  Per discussion with engineering filing the following BZ.

mmccune: would be super easy to add
mmccune: do we have a BZ for this?
mmccune: if not, can you file? ill get it acked-up
mmccune: https://github.com/Katello/katello-packaging/blob/master/katello/katello-debug.sh
mmccune: that is the actual script that we would add it to
mmccune: the easiest is:
mmccune:  du -sh /var/lib/pulp /var/lib/mongodb/ /var/lib/pgsql/
mmccune: df -h
mmccune: those 2

Version-Release number of selected component (if applicable):
Satellite 6.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Chris Roberts 2017-01-14 03:08:51 UTC
Running du -sh will take to long, getting a df -h to verify disk space on the entire FS

Comment 4 jcallaha 2017-02-13 19:46:15 UTC
Verified in Satellite 6.2.8 Snap 2. Added three files detailing disk space usage (disk_space_output, mongodb_disk_space, postgres_disk_space)

-bash-4.1# foreman-debug
Processing... (takes a while)Exporting tasks, this may take a few minutes.
Copying entire file: /tmp/task-export-1487014445.tar.gz


 HOSTNAME: ibm-x3550m3-12.lab.eng.brq.redhat.com
       OS: redhat
  RELEASE: Red Hat Enterprise Linux Server release 6.8 (Santiago)
  FOREMAN: 1.11.0.66
     RUBY: ruby 1.8.7 (2013-06-27 patchlevel 374) [x86_64-linux]
   PUPPET: 3.8.6
  DENIALS: 0


A debug file has been created: /tmp/foreman-debug-OVhf9.tar.xz (1243704 bytes)

To upload a tarball to our secure site, please use the -u option.


-bash-4.1# tar -xvJf foreman-debug-OVhf9.tar.xz

-bash-4.1# cat foreman-debug-OVhf9/disk_space_output 
COMMAND> df -h

Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_ibmx3550m312-lv_root
                      446G   12G  411G   3% /
tmpfs                  12G     0   12G   0% /dev/shm
/dev/sda1             477M   71M  382M  16% /boot

-bash-4.1# cat foreman-debug-OVhf9/mongodb_disk_space 
COMMAND> du -sh /var/lib/mongodb

4.7G	/var/lib/mongodb

-bash-4.1# cat foreman-debug-OVhf9/postgres_disk_space 
COMMAND> du -sh /var/lib/pgsql

182M	/var/lib/pgsql

Comment 6 errata-xmlrpc 2017-03-06 08:37:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0447


Note You need to log in before you can comment on or make changes to this bug.