Bug 1413157 - Expose Tuning Swift Object, Container, Account server process counts
Summary: Expose Tuning Swift Object, Container, Account server process counts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Christian Schwede (cschwede)
QA Contact: Mike Abrams
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 18:39 UTC by Alex Krzos
Modified: 2018-06-27 13:31 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost puppet-swift-12.2.0-0.20180119083117.de58ee9.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:29:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 497825 None MERGED Expose account/container/object worker count 2020-07-09 07:26:46 UTC
OpenStack gerrit 497917 None MERGED Expose account/container/object worker count 2020-07-09 07:26:46 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:31:13 UTC

Description Alex Krzos 2017-01-13 18:39:01 UTC
Description of problem:
Swift deployed by tripleo using OSPd deploys single swift-object-server, swift-container-server, and swift-account-server processes which can/will affect the scalability and performance of your Swift.  General Swift tuning guide recommends a one to one ratio of physical cpu to process counts for these processes with a single concurrency for the background tasks with ther exception of the replicators [0]

Version-Release number of selected component (if applicable):
OSP10

How reproducible:
Always

Steps to Reproduce:
1. Deploy overcloud and review process counts of the swift services
2.
3.

Actual results:


Expected results:


Additional info:

Related bug https://bugzilla.redhat.com/show_bug.cgi?id=1411391

[0] http://docs.openstack.org/developer/swift/deployment_guide.html#general-service-tuning

Comment 1 Paul Grist 2017-04-06 02:22:20 UTC
This may be covered by some WIP and doc changes coming, over to Swift to comment/triage.

Comment 2 Christian Schwede (cschwede) 2017-08-25 10:33:26 UTC
It's possible to set the workers count using a template with the proposed patch for puppet-swift applied like this:

parameter_defaults:
  ControllerExtraConfig:
    swift::storage::all::account_server_workers: 3
    swift::storage::all::container_server_workers: 5
    swift::storage::all::object_server_workers: 7

Comment 3 Christian Schwede (cschwede) 2017-08-25 11:43:07 UTC
Also proposed a t-h-t patch to simplify this:

parameter_defaults:
  SwiftAccountWorkers: 3
  SwiftContainerWorkers: 5
  SwiftObjectWorkers: 7

Comment 4 Christian Schwede (cschwede) 2017-09-21 15:35:51 UTC
Merged after release - moving to 13.

Comment 10 Tzach Shefi 2018-02-26 07:23:14 UTC
Still waiting on newer puddle
Last one I managed to deploy today, none sufficient yet > 2018-02-14.1

Comment 16 errata-xmlrpc 2018-06-27 13:29:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.