Bug 141316 - The updated kernel kernel-2.6.9-1.6_FC2 does not recognise the swap partition
The updated kernel kernel-2.6.9-1.6_FC2 does not recognise the swap partition
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 06:13 EST by Christophe Osinski
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-12 23:43:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christophe Osinski 2004-11-30 06:13:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3)
Gecko/20040921

Description of problem:
The default istallation of Fedora Core 2 (kernel-2.6.5-1.358) came
with 2Gb of swap. When I rebooted with the altest version of the
kernel (kernel-2.6.9-1.6_FC2) updated using up2date, it marked at boot
that it couldn't load the swap partition, and when I run top it prints:
Swap:  0k total

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.6_FC2

How reproducible:
Always

Steps to Reproduce:
1. boot with the kernel version 2.6.9-1.6_FC2
    

Actual Results:  No Swap!

Expected Results:  top shows:
Swap:  2040244k total

Additional info:
Comment 1 Dave Jones 2004-11-30 11:55:54 EST
what are the results of..

swapon -s

fdisk -l

grep swap /etc/fstab
Comment 2 Christophe Osinski 2004-11-30 12:57:16 EST
swapon -s

gives nothing, but

fdisk -l

gives me the following output:

Disk /dev/sda: 163.9 GB, 163928604672 bytes
255 heads, 63 sectors/track, 19929 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14       19675   157935015   83  Linux
/dev/sda3           19676       19929     2040255   82  Linux swap

while

grep swap /etc/fstab

gives me the following output

/dev/hde3               swap                    swap    defaults        0 0

I have a SATA disk and the installation of Fedora Core 2 recognized it as
/dev/hde, and it seems that it is the point
Comment 3 Dave Jones 2005-02-12 23:43:08 EST
indeed, that hde should be an sda3.

seems due to the fact that libata appeared post 2.6.5 and changed the device node
that you use.

Ouch.  Short of fixing it up by hand, there's not a lot else we can do.

Note You need to log in before you can comment on or make changes to this bug.