Bug 1413164 - [RFE] Make ceph 2.0 radosgw swift to expose all the APIs required to be validate by OpenStack Tempest
Summary: [RFE] Make ceph 2.0 radosgw swift to expose all the APIs required to be valid...
Keywords:
Status: CLOSED DUPLICATE of bug 1252600
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 2.2
Assignee: Matt Benjamin (redhat)
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 19:19 UTC by Andrea Perotti
Modified: 2017-07-30 15:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-13 20:08:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2858981 None None None 2017-01-13 19:39:20 UTC

Description Andrea Perotti 2017-01-13 19:19:49 UTC
3. What is the nature and description of the request? 
Customer is looking to have all the swift API used by OpenStack Tempest 

4. Why does the customer need this? (List the business requirements here)
Customer will face soon some OpenStack release upgrades and his validation plan include practical tests made with Tempest

5. How would the customer like to achieve this? (List the functional requirements here)
Implementing all the various blocking BZs to this one and more in general implementing all the missing APIs, starting from /info

8. Does the customer have any specific timeline dependencies?
End of Q1 of 2017, in time for allowing them to execute their migration plans.

9. Is the sales team involved in this request and do they have any additional input?
no 

11. Would the customer be able to assist in testing this functionality if implemented?
Yes, sure

Where are you experiencing the behavior?  What environment?
RFE

When does the behavior occur? Frequently?  Repeatedly?   At certain times?
RFE

What information can you provide around timeframes and urgency?
RFE

Comment 3 Andrea Perotti 2017-01-13 20:08:34 UTC

*** This bug has been marked as a duplicate of bug 1252600 ***


Note You need to log in before you can comment on or make changes to this bug.