Bug 1413177 - Circular dependencies in the V2 driver
Summary: Circular dependencies in the V2 driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-odl
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z1
: 10.0 (Newton)
Assignee: Mike Kolesnik
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 20:10 UTC by Mike Kolesnik
Modified: 2018-10-18 07:18 UTC (History)
3 users (show)

Fixed In Version: python-networking-odl-3.2.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-01-26 16:42:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0201 0 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2017-01-26 21:40:54 UTC

Description Mike Kolesnik 2017-01-13 20:10:04 UTC
Description of problem:
After running tempest I see there's 100+ rows pending in the journal with the journal trying to process them in cycles and skipping because they're failing the dependency check.
This is obviously indicative of some circular dependency which needs to be broken.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Mike Kolesnik 2017-01-15 07:40:37 UTC
Before the fix running the tempest suite would result in rows remaining in the opendaylightjournal table indefinitely in a 'pending'/'processing' state. 

After the fix the opendaylightjournal table shouldn't have any such rows and they all should be in 'completed' state (or empty if the completed rows were purged).

Comment 5 Itzik Brown 2017-01-22 12:35:21 UTC
Used:
python-networking-odl-3.2.0-2.el7ost

Ran several tempest tests and all records are in 'completed' state.

Comment 7 errata-xmlrpc 2017-01-26 16:42:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0201.html


Note You need to log in before you can comment on or make changes to this bug.