Bug 1413197 - Allow RGW to be installed/configured by an API endpoint
Summary: Allow RGW to be installed/configured by an API endpoint
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Andrew Schoen
QA Contact: Tejas
URL:
Whiteboard:
Depends On:
Blocks: 1406357
TreeView+ depends on / blocked
 
Reported: 2017-01-13 21:46 UTC by Christina Meno
Modified: 2017-06-19 13:16 UTC (History)
10 users (show)

Fixed In Version: ceph-installer-1.3.0-1.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-19 13:16:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1317992 0 unspecified CLOSED [RFE] RGW Install (using ceph-installer) 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2017:1496 0 normal SHIPPED_LIVE ceph-installer, ceph-ansible, and ceph-iscsi-ansible update 2017-06-19 17:14:02 UTC

Internal Links: 1317992

Description Christina Meno 2017-01-13 21:46:31 UTC
Description of problem:
ceph-ansible supports install/configuration of RGW
we need to provide this via ceph-installer
Include API docs for the same

* support all options documented here 

https://access.redhat.com/documentation/en/red-hat-ceph-storage/2/paged/installation-guide-for-red-hat-enterprise-linux/chapter-4-client-installation#ansible-install-rgw

* Exclude containerized deployment as that is not GA in Current release of RHCS 

* Exclude multi-site configuration in the first pass as the docs don't state that ceph-ansible supports configuration of RGW multi-site

https://access.redhat.com/documentation/en/red-hat-ceph-storage/2/single/object-gateway-guide-for-red-hat-enterprise-linux#multi_site

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Nishanth Thomas 2017-01-25 04:33:39 UTC
Will you also enable the management of RGW through calamari? if not how to do the day 2 management of RGw from management station like Tendrl?

Comment 3 Christina Meno 2017-02-06 19:04:47 UTC
Right now the challenge is that calamari doens't know where the RGW gateways are as they don't have to be hosted on monitors.

I had not planned to support this be console 3

Comment 4 Andrew Schoen 2017-02-15 16:17:38 UTC
PR opened upstream for ceph-installer: https://github.com/ceph/ceph-installer/pull/193

Comment 5 Ken Dreyer (Red Hat) 2017-03-02 16:51:50 UTC
Need a new upstream version tagged with this change.

Comment 10 Alfredo Deza 2017-05-17 15:06:33 UTC
The full list of monitors is required. The schema validation is responding poorly here.

Required fields for this endpoint are:

* fsid (string)
* host (string)
* monitors (list)
* public_network (string)

Note also you are passing a list for "hosts", but we require "host" as a string.

Comment 11 John Poelstra 2017-05-17 15:19:03 UTC
discussed at program meeting, Gregory will have root cause and estimate today

Comment 12 Andrew Schoen 2017-05-17 15:29:27 UTC
Tejas,

Could you please try again with the 'monitors' field included? It works the same way an osd configure api call does.

Here are the docs from the osd configure endpoint:

monitors (array) – (required) The monitors for the cluster you want to add this OSD to. Provide a list of objects representing the monitor host and its interface or address.

for example: "monitors": [{"host": "mon0.host", "interface": "eth1"}, {"host": "mon1.host", "address": "10.0.0.1"}]

I also noticed that we've neglected to include docs for the rgw endpoint. I'll get those updated. I believe Alfredo has provided a patch to pecan-notario ( the system that performs the schema validation ) to fix the poor reporting here.

Thanks!

Comment 13 Alfredo Deza 2017-05-17 16:21:22 UTC
The doc reference: http://docs.ceph.com/ceph-installer/docs/#post--api-rgw-configure-

Comment 16 Tejas 2017-05-18 06:36:04 UTC
My bad, RGW configure is working fine on build ceph-installer-1.3.0-1.el7scon.noarch
Moving this to verified.

Comment 18 errata-xmlrpc 2017-06-19 13:16:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1496


Note You need to log in before you can comment on or make changes to this bug.