Bug 1413247 - Upgrade to Mono 4.8
Summary: Upgrade to Mono 4.8
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mono
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavier Lamien
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1426201 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-14 05:37 UTC by Timotheus Pokorra
Modified: 2017-02-23 17:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-23 17:37:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Timotheus Pokorra 2017-01-14 05:37:27 UTC
First of all, I don't know if we need to wait until Fedora 26 gets branched from Rawhide (2017-02-21). It might be too late to get Mono 4.8 into Fedora 26.

Apart from that, I am at least trying to do scratch builds for the first release candidate for Mono 4.8, 4.8.0.429 https://releases.xamarin.com/beta-release-cycle-9-rc-builds/

I will report issues here that happen for the scratch build.

Comment 1 Timotheus Pokorra 2017-01-17 14:20:57 UTC
I have the spec file and patches here: https://github.com/tpokorra/lbs-mono-fedora/tree/master/mono

The scratch build https://koji.fedoraproject.org/koji/taskinfo?taskID=17276095
worked for x86_64, i686, aarch64 and armv7hl.

for ppc64 I have filed this bug upstream: https://bugzilla.xamarin.com/show_bug.cgi?id=51573

for ppc64le I have filed this bug upstream: https://bugzilla.xamarin.com/show_bug.cgi?id=51572

both bugs have the build log attached.

Comment 2 Timotheus Pokorra 2017-02-23 16:27:03 UTC
*** Bug 1426201 has been marked as a duplicate of this bug. ***

Comment 3 Timotheus Pokorra 2017-02-23 17:37:28 UTC
seems the bugs for ppc64 and ppc64le have been resolved upstream. I don't get the build errors anymore.

We now have Mono 4.8 in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.