Bug 1413251 - xorg-server switched to modeset driver for intel cards
Summary: xorg-server switched to modeset driver for intel cards
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-14 06:50 UTC by Branko Grubić
Modified: 2017-09-13 12:44 UTC (History)
8 users (show)

Fixed In Version: xorg-x11-server-1.19.1-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-19 05:56:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Branko Grubić 2017-01-14 06:50:20 UTC
Description of problem:
Latest xorg-x11-server uses modeset driver instead of intel.
I know this is planed for >=f26 but not on f25.

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.19.1-1.fc25.x86_64
xorg-x11-drv-intel-2.99.917-26.20160929.fc25.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])



[    63.010] (==) Matched modesetting as autoconfigured driver 0
[    63.010] (II) LoadModule: "modesetting"
[    63.010] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[    63.011] (II) Module modesetting: vendor="X.Org Foundation"
[    63.024] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    63.025] (II) modeset(0): using drv /dev/dri/card0
[    63.030] (II) modeset(0): Creating default Display subsection in Screen section
[    63.030] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[    63.030] (==) modeset(0): RGB weight 888
[    63.030] (==) modeset(0): Default visual is TrueColor
[    63.051] (II) modeset(0): glamor initialized

Comment 1 sean darcy 2017-01-14 23:09:01 UTC
And, at least for new intel cpu's, the modesetting driver fails :

[114614.766] (II) Loading /usr/lib64/xorg/modules/libfb.so
[114614.767] (II) Module fb: vendor="X.Org Foundation"
[114614.767] 	compiled for 1.19.1, module version = 1.0.0
[114614.767] 	ABI class: X.Org ANSI C Emulation, version 0.4
..........
[114614.768] (==) Depth 24 pixmap format is 32 bpp
[114614.768] (WW) glamor0: Failed to get GLSL version
[114614.768] (EE) modeset(0): Failed to initialize glamor at ScreenInit() time.
[114614.768] (EE) 
Fatal server error:
[114614.768] (EE) AddScreen/ScreenInit failed for driver 0

lspci -v | grep VGA
00:02.0 VGA compatible controller: Intel Corporation HD Graphics P530 (rev 06) (prog-if 00 [VGA controller])

Comment 2 sean darcy 2017-01-14 23:22:45 UTC
filed a separate bug on modesetting failure :

https://bugzilla.redhat.com/show_bug.cgi?id=1413318

Comment 3 Daniele Viganò 2017-01-15 10:57:24 UTC
This change makes some resolutions unavailable on my laptop with a 1920x1080 panel and Intel HD 4400.

After the upgrade all 16:9 resolutions (a part from 1920x1080) disappeared, like 1600x900 that sometime I use.

Downgrading to 1.19.0-0.3.20161026.fc25.x86_64 everything is working as expected.

Comment 4 Fedora Update System 2017-01-16 16:53:58 UTC
xorg-x11-server-1.19.1-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-35539a542c

Comment 5 Fedora Update System 2017-01-17 21:49:57 UTC
xorg-x11-server-1.19.1-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-35539a542c

Comment 6 Fedora Update System 2017-01-19 05:56:03 UTC
xorg-x11-server-1.19.1-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Sergio Basto 2017-09-13 12:44:04 UTC
JFTR , in Fedora 25 I'm tracing a long stand bug and seems xorg-x11-drv-intel-2.99.917-26.20160929.fc25.x86_64 is the problem , it some circumstances system slowdown a lot and is impossible to work, laptop gets very hot, processes take 100% of CPU and no explanation for that, after switch to modeset i.e. dnf remove xorg-x11-drv-intel . The laptop seems that get back to normal i.e. no processes taking 100% of CPU etc etc 

Also sometimes I got a little screen corruption specially on "GTK+ applications in KDE" and seems is also xorg-x11-drv-intel fault this happen since F23 or so .

So in conclusion I would recommend revert the fix in this bug report, should I reopen this ticket ?


Note You need to log in before you can comment on or make changes to this bug.