Bug 1413292 - syste-config-kickstart - Cannot install on Fedora 25 - RPM Requirement Wrong
Summary: syste-config-kickstart - Cannot install on Fedora 25 - RPM Requirement Wrong
Keywords:
Status: CLOSED DUPLICATE of bug 1406598
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kickstart
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-14 15:37 UTC by Jacques Duplessis
Modified: 2017-11-27 18:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-27 18:12:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Jacques Duplessis 2017-01-14 15:37:35 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. dnf install system-config-kickstart
2. Failed - require system-config-date ?
3. dnf install system-config-date
4. No package system-config-data available


Actual results:
root@fedora25~# yum install system-config-kickstart
Redirecting to '/usr/bin/dnf install system-config-kickstart' (see 'man yum2dnf')

Last metadata expiration check: 0:14:13 ago on Sat Jan 14 10:16:02 2017.
Error: nothing provides system-config-date needed by system-config-kickstart-2.9.3-3.fc24.noarch
(try to add '--allowerasing' to command line to replace conflicting packages)
root@fedora25~# yum install system-config-date
Redirecting to '/usr/bin/dnf install system-config-date' (see 'man yum2dnf')

Last metadata expiration check: 0:14:20 ago on Sat Jan 14 10:16:02 2017.
No package system-config-date available.
Error: Unable to find a match.
root@fedora25~# 

Tried before and after installing python-kickstart - No Change
root@fedora25~# rpm -qa | grep -i kickstart
python3-kickstart-2.32-1.fc25.noarch
python-kickstart-2.32-1.fc25.noarch
root@fedora25~# 

root@fedora25~# date
Sat Jan 14 10:36:26 EST 2017

root@fedora25~# uname -a
Linux fedora25.maison.ca 4.8.16-300.fc25.x86_64 #1 SMP Fri Jan 6 18:11:49 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

root@fedora25~# dnf -y update
Last metadata expiration check: 0:20:31 ago on Sat Jan 14 10:16:02 2017.
Dependencies resolved.
======================================================================================================================================
 Package                             Arch                        Version                           Repository                    Size
======================================================================================================================================
Skipping packages with broken dependencies:
 cockpit-bridge                      x86_64                      127-1.fc25                        updates                      450 k

Transaction Summary
======================================================================================================================================
Skip  1 Package

Nothing to do.
Complete!
root@fedora25~# 

Expected results:
Package should installable and working

Additional info:

Comment 1 Ferdinand Holzer 2017-07-13 18:10:38 UTC
Seems system-config-date is the only missing dependency. As a workaround i just used system-config-date from some fc24 repo. e.g. http://fedora.inode.at/releases/24/Everything/x86_64/os/Packages/s/system-config-date-1.10.9-2.fc24.noarch.rpm
All other dependencies were present in the default fc25 release/update repositories.

Comment 2 Tim Landscheidt 2017-09-28 23:11:46 UTC
This is a duplicate of bug #1406598.

Comment 3 Fedora End Of Life 2017-11-16 19:01:20 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 4 Chris Lumens 2017-11-27 18:12:40 UTC

*** This bug has been marked as a duplicate of bug 1406598 ***


Note You need to log in before you can comment on or make changes to this bug.