Bug 1413352 - [Scale] : Rebalance status shows successful even though it failed on one of the nodes.
Summary: [Scale] : Rebalance status shows successful even though it failed on one of t...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Nithya Balachandran
QA Contact: Ambarish
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-15 10:15 UTC by Ambarish
Modified: 2017-01-16 09:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 09:57:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ambarish 2017-01-15 10:15:05 UTC
Description of problem:
-----------------------

CLI shows *volume rebalance: butcher: success*,even though there are rebalance failures. 

[root@gqas009 ~]# gluster v rebalance butcher status
                                    Node Rebalanced-files          size       scanned      failures       skipped               status  run time in h:m:s
                               ---------      -----------   -----------   -----------   -----------   -----------         ------------     --------------
                               localhost                0        0Bytes             0             0             0            completed        0:13:31
      gqas015.sbu.lab.eng.bos.redhat.com                0        0Bytes             0             0             0            completed        0:14:27
      gqas014.sbu.lab.eng.bos.redhat.com                0        0Bytes           260             0             0            completed        0:13:1
      gqas010.sbu.lab.eng.bos.redhat.com            30338       162.4GB        177268             8             0               failed        8:16:47
volume rebalance: butcher: success
[root@gqas009 ~]# 

Version-Release number of selected component (if applicable):
-------------------------------------------------------------

glusterfs-3.8.4-11.el7rhgs.x86_64

How reproducible:
-----------------

1/1

Actual results:
----------------

Rebalance CLI outputs two contradictory statements.  

Expected results:
-----------------

Since "success" means something good,CLI should show success only if the process completed successfully.

Additional info:
-----------------

None.

Comment 3 Samikshan Bairagya 2017-01-16 09:57:39 UTC
gluster v rebalance <volname> status would return a "failed" status only if the command itself fails. Here, the rebalance status command has completed successfully to provide the required information wrt rebalance and hence you get a "volume rebalance: butcher: success" output. This is an expected output and not a bug.


Note You need to log in before you can comment on or make changes to this bug.