Bug 1413388 - journalctl "Journal file uses an unsupported feature"
Summary: journalctl "Journal file uses an unsupported feature"
Keywords:
Status: CLOSED DUPLICATE of bug 1404406
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-15 16:57 UTC by Alan Hamilton
Modified: 2017-01-16 14:01 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 11:56:20 UTC


Attachments (Terms of Use)

Description Alan Hamilton 2017-01-15 16:57:26 UTC
Description of problem:
When running journalctl, a warning appears similar to
Journal file /var/log/journal/fe39ba83b9244251b1704fc655fbff2f/user-1001@e66940142e9245e589cc6aea5aad7b48-00000000008cbf92-0005425873910c71.journal uses an unsupported feature, ignoring file.

Version-Release number of selected component (if applicable):
systemd-231-11.fc25.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Run journalctl, with most options. journalctl --verify shows it.

Actual results:
Journal file /var/log/journal/fe39ba83b9244251b1704fc655fbff2f/user-1001@e66940142e9245e589cc6aea5aad7b48-00000000008cbf92-0005425873910c71.journal uses an unsupported feature, ignoring file.

Expected results:
No warnings.

Additional info:
The warning indicates the file is using compression that journalctl doesn't recognize. journalctl in this package appears to have been built without LZ4 support.

From systemd-231-10.fc25.x86_64
$ journalctl --version
systemd 231
+PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN

From systemd-231-11.fc25.x86_64
$ journalctl --version
systemd 231
+PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ -LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN

Note the "-LZ4".

Comment 1 Joachim Backes 2017-01-16 11:43:01 UTC
Seeing this too, if simply running "journalctl"

journalctl
Journal file /var/log/journal/8e494e07f3a7423b8ac7661fff29d5ca/system@b100186ab24446dfb33dcac51eb22c4d-0000000000000001-000532f5dc539aa5.journal uses an unsupported feature, ignoring file.
-- No entries --

Comment 2 Joachim Backes 2017-01-16 11:45:47 UTC
(In reply to Joachim Backes from comment #1)
> Seeing this too, if simply running "journalctl"
> 
> journalctl
> Journal file
> /var/log/journal/8e494e07f3a7423b8ac7661fff29d5ca/
> system@b100186ab24446dfb33dcac51eb22c4d-0000000000000001-000532f5dc539aa5.
> journal uses an unsupported feature, ignoring file.
> -- No entries --

Forgotten:

journalctl --version
systemd 231
+PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ -LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN

Comment 3 Joachim Backes 2017-01-16 11:55:53 UTC
(In reply to Joachim Backes from comment #2)
> (In reply to Joachim Backes from comment #1)
> > Seeing this too, if simply running "journalctl"
> > 
> > journalctl
> > Journal file
> > /var/log/journal/8e494e07f3a7423b8ac7661fff29d5ca/
> > system@b100186ab24446dfb33dcac51eb22c4d-0000000000000001-000532f5dc539aa5.
> > journal uses an unsupported feature, ignoring file.
> > -- No entries --
> 
> Forgotten:
> 
> journalctl --version
> systemd 231
> +PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP
> +GCRYPT +GNUTLS +ACL +XZ -LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN

After downgrading systemd to systemd-231-10.fc25.x86_64, journalctl works properly :-)

Comment 4 Jan Synacek 2017-01-16 11:56:20 UTC
I'm working on it.

*** This bug has been marked as a duplicate of bug 1404406 ***


Note You need to log in before you can comment on or make changes to this bug.