Bug 1413439 - Virtio scsi cdrom can't be found in RHEL6.x guest
Summary: Virtio scsi cdrom can't be found in RHEL6.x guest
Keywords:
Status: CLOSED DUPLICATE of bug 1413448
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.4
Hardware: ppc64le
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Gibson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 02:06 UTC by Xujun Ma
Modified: 2017-01-16 15:43 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 15:43:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Xujun Ma 2017-01-16 02:06:44 UTC
Description of problem:
Virtio scsi cdrom can't be used in RHEL6.x guest

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.8.0-1.el7.ppc64le
guest:RHEL-6.9-20170111.0-Server-ppc64-dvd1.iso 
hostkernel:3.10.0-537.el7.ppc64le


How reproducible:
100%

Steps to Reproduce:
1.run guest with cmdlines to install rhel6.9 os:
/usr/libexec/qemu-kvm \
 -name test \
 -smp 4 \
 -m 4096 \
 -M pseries \
 -rtc base=utc,clock=vm \
 -nodefaults \
 -serial stdio \
 -device virtio-scsi-pci,bus=pci.0 \
 -device scsi-hd,id=scsi-hd0,drive=scsi-hd0-dr0,bootindex=1 \
 -drive file=RHEL-6.9-20170111.0-ppc64.qcow2,if=none,id=scsi-hd0-dr0,format=qcow2,cache=none \
 -device scsi-cd,id=scsi-cd1,drive=scsi-cd1-dr1,bootindex=0 \
 -drive file=RHEL-6.9-20170111.0-Server-ppc64-dvd1.iso,if=none,id=scsi-cd1-dr1,readonly=on,format=raw,cache=none \
 -device virtio-net-pci,netdev=net0,id=nic0,mac=52:54:00:c4:e7:84 \
 -netdev tap,id=net0,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown,vhost=on \

2.Choose a Language and  Local CD/DVD  

3.

Actual results:
┌─────────────────┤ No driver found ├──────────────────┐
            │                                                      │
            │        Unable to find any devices of the type        │
            │        needed for this installation type.            │
            │        Would you like to manually select your        │
            │        driver or use a driver disk?                  │
            │                                                      │
            │ ┌───────────────┐   ┌───────────────────┐  ┌──────┐  │
            │ │ Select driver │   │ Use a driver disk │  │ Back │  │
            │ └───────────────┘   └───────────────────┘  └──────┘  │
            │                                                      │
            │                                                      │
            └──────────────────────────────────────────────────────┘



Expected results:
begin to install guest os.

Additional info:

Comment 2 Laurent Vivier 2017-01-16 14:38:29 UTC
Please re-test with qemu-kvm-rhev-2.8.0-2.el7, as -1 doesn't have the pseries-rhel7.4.0 machine.

Comment 3 Laurent Vivier 2017-01-16 15:43:50 UTC
I think the cdrom is not found because virtio-scsi-pci doesn't work correctly, and this is described in BZ1413448. So I close this one.

*** This bug has been marked as a duplicate of bug 1413448 ***


Note You need to log in before you can comment on or make changes to this bug.