Bug 1413463 - update to http-parser 2.7 breaks ocserv
Summary: update to http-parser 2.7 breaks ocserv
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: http-parser
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 03:52 UTC by Dennis Gilmore
Modified: 2020-03-24 07:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 07:39:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Dennis Gilmore 2017-01-16 03:52:41 UTC
Description of problem:

ocserv fails to run correctly when http-parser-2.7.1-3.el7 is installed.

[16341.460896] traps: ocserv-worker[32416] general protection ip:7fe9032d8103 sp:7fffbecb9a30 error:0 in libhttp_parser.so.2.7[7fe9032d5000+6000]
 shows up in dmesg, I have tried to rebuild ocserv against the new http-parser however the result is the same. seems there is an issue with http-parser-2.7 in EL7

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Stephen Gallagher 2017-01-16 13:08:47 UTC

*** This bug has been marked as a duplicate of bug 1411021 ***

Comment 2 Dennis Gilmore 2017-01-16 15:05:39 UTC
I do not believe this is a dupe, I believe it is a code issue with http-parser, a rebuild of ocserv did not help, additionally ocserv does not segfault. the tls connection is malformed and can not be fully connected.

Comment 3 Nikos Mavrogiannopoulos 2018-04-11 08:44:50 UTC
There were quite many changes since then and ocserv should work now. Closing, but feel free to re-open if I am wrong.


Note You need to log in before you can comment on or make changes to this bug.