Bug 1413486 - [RFE] Provision for Director to omit specific stacks during stack-updates. [NEEDINFO]
Summary: [RFE] Provision for Director to omit specific stacks during stack-updates.
Keywords:
Status: CLOSED DUPLICATE of bug 1395308
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 9.0 (Mitaka)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 06:19 UTC by Navneet Krishnan
Modified: 2020-04-15 15:06 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-24 19:48:18 UTC
Target Upstream Version:
nkrishna: needinfo? (athomas)


Attachments (Terms of Use)

Description Navneet Krishnan 2017-01-16 06:19:09 UTC
Description of problem:

When performing a stack update which includes operations such as compute scaling, minor or major updates, certain templates should not be touched to compliment certain advanced manual configuration. This scenario would cover certain environments that are hybrid director and manual deployments. Therefore even standard operations such as compute scaling via director would break this environment. 

 Usually manual configurations are not advised and all configuration made on the overcloud should be done via the director. But there exists, certain configurations that cannot be performed via json or yaml templates nor can they be re-applied via post configuration scripts.




Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Jaromir Coufal 2017-07-24 19:48:18 UTC
This will be supported method for OSP12. Closign as duplicate of existing RFE.

*** This bug has been marked as a duplicate of bug 1395308 ***


Note You need to log in before you can comment on or make changes to this bug.