Bug 1413489 - Inspection doesn't find any OS in cirros-d161201-x86_64-disk.img
Summary: Inspection doesn't find any OS in cirros-d161201-x86_64-disk.img
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 07:04 UTC by Richard W.M. Jones
Modified: 2017-06-20 09:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-20 09:49:01 UTC


Attachments (Terms of Use)
virt-inspector -v -x output (75.63 KB, text/plain)
2017-01-16 07:05 UTC, Richard W.M. Jones
no flags Details

Description Richard W.M. Jones 2017-01-16 07:04:42 UTC
Description of problem:

$ wget http://download.cirros-cloud.net/daily/20161201/cirros-d161201-x86_64-disk.img
$ virt-inspector cirros-d161201-x86_64-disk.img 
<?xml version="1.0"?>
<operatingsystems/>

Version-Release number of selected component (if applicable):

libguestfs-tools-c-1.35.18-1.fc26.x86_64

How reproducible:

100%

Steps to Reproduce:
1. See above.

Comment 1 Richard W.M. Jones 2017-01-16 07:05:10 UTC
Created attachment 1241121 [details]
virt-inspector -v -x output

Comment 2 Richard W.M. Jones 2017-01-16 07:06:10 UTC
I should say that this bug was originally reported on IRC by
Nadav Goldin from Red Hat.

Comment 3 Pino Toscano 2017-01-16 09:30:55 UTC
It looks like this version has just a minimal / partition with grub1 (in /boot), kernel, and initrd -- all the system is within the initrd.

Comment 4 Nadav Goldin 2017-06-20 08:43:18 UTC
I think this can be closed, the official CirrOS 0.3.5 works:

virt-inspector cirros-0.3.5-x86_64-disk.img 
<?xml version="1.0"?>
<operatingsystems>
  <operatingsystem>
    <root>/dev/sda1</root>
    <name>linux</name>
    <arch>x86_64</arch>
    <distro>cirros</distro>
    <product_name>0.3.5</product_name>
    <major_version>0</major_version>
    <minor_version>3</minor_version>
    <hostname>cirros</hostname>
    <format>installed</format>
    <mountpoints>
      <mountpoint dev="/dev/sda1">/</mountpoint>
    </mountpoints>
    <filesystems>
      <filesystem dev="/dev/sda1">
        <type>ext3</type>
        <label>cirros-rootfs</label>
        <uuid>35a2ae36-b422-4230-9c8c-0bbf24dd684b</uuid>
      </filesystem>
    </filesystems>
    <applications/>
  </operatingsystem>
</operatingsystems>


Back then I used a not officially released image, not sure if it was a bug in libguestfs or a broken image, either way, thanks!

Comment 5 Richard W.M. Jones 2017-06-20 09:49:01 UTC
Closing per comment 4.  Thanks for testing it!


Note You need to log in before you can comment on or make changes to this bug.