Bug 1413493 - Failed to add rhvh to engine due to "Package fluentd cannot be found"
Summary: Failed to add rhvh to engine due to "Package fluentd cannot be found"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-ng
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ovirt-4.1.0-rc
: ---
Assignee: Sandro Bonazzola
QA Contact: dguo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 07:41 UTC by dguo
Modified: 2017-04-20 19:02 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-04-20 19:02:33 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
engine/ vdsm log (148.10 KB, application/x-gzip)
2017-01-16 07:41 UTC, dguo
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1114 normal SHIPPED_LIVE redhat-virtualization-host bug fix and enhancement update 2017-04-20 22:57:46 UTC

Description dguo 2017-01-16 07:41:12 UTC
Created attachment 1241122 [details]
engine/ vdsm log

Description of problem:
Failed to add rhvh4.1 to engine due to "Package fluentd cannot be found"

Version-Release number of selected component (if applicable):
Red Hat Virtualization Manager Version: 4.1.0-0.3.beta2.el7
redhat-virtualization-host-4.1-20170112.1
imgbased-0.9.4-0.1.el7ev.noarch
vdsm-4.19.1-1.el7ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install a rhvh4.1 via anaconda UI
2. Add this host to engine4.1

Actual results:
1. Failed to install Host dguo_local. Yum Cannot queue package fluentd: Package fluentd cannot be found.

Expected results:
1. After step#3, the host can be added to engine successfully

Additional info:

Comment 3 Sandro Bonazzola 2017-01-16 08:02:07 UTC
fluentd is required by ovirt-hosted-engine-setup so it should be within the image.
We'll build ovirt-hosted-engine-setup for today RC and rebuild the image right after.

Comment 4 cshao 2017-01-19 09:10:35 UTC
Test version:
redhat-virtualization-host-4.1-20160116.0.x86_64
Red Hat Virtualization Manager Version: 4.1.0-0.3.beta2.el7
imgbased-0.9.4-0.1.el7ev.noarch
vdsm-4.19.1-1.el7ev.x86_64
fluentd-0.12.29-1.el7.noarch

Test result:
RHVH can be added to engine successfully now.

Comment 5 cshao 2017-01-20 06:51:46 UTC
Verify this bug according #c4.

Comment 6 errata-xmlrpc 2017-04-20 19:02:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1114


Note You need to log in before you can comment on or make changes to this bug.