Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1413499 - virt-inspector can't obtain info from rhel7.3 guest image on rhel6.9 host
Summary: virt-inspector can't obtain info from rhel7.3 guest image on rhel6.9 host
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.9
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 08:29 UTC by mxie@redhat.com
Modified: 2017-01-23 14:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-23 14:06:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
virt-inspector2-rhel7.3 (53.54 KB, text/plain)
2017-01-16 08:29 UTC, mxie@redhat.com
no flags Details

Description mxie@redhat.com 2017-01-16 08:29:17 UTC
Created attachment 1241138 [details]
virt-inspector2-rhel7.3

Description of problem:
virt-inspector can't obtain info from rhel7.3 guest image on rhel6.9 host

Version-Release number of selected component (if applicable):
libvirt-0.10.2-62.el6.x86_64
python-libguestfs-1.20.11-20.el6.x86_64
libguestfs-1.20.11-20.el6.x86_64
libguestfs-winsupport-1.0-7.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.501.el6.x86_64 


How reproducible:
100%

Steps to Reproduce:
1 Prepare a rhel7.3 guest and using virt-inspector to obtain the info from guest image
# virt-inspector rhel7.3.img
No operating system could be detected inside this disk image.

This may be because the file is not a disk image, or is not a virtual machine
image, or because the OS type is not understood by virt-inspector.

If you feel this is an error, please file a bug report including as much
information about the disk image as possible.

2.Try to use virt-inspector2 to obtain the info from rhel7.3 guest image, details pls refer to log"virt-inspector2-rhel7.3" 
# virt-inspector2 rhel7.3.img
<?xml version="1.0"?>
<operatingsystems/>


Actual results:
virt-inspector can't obtain info from rhel7.3 guest image on rhel6.9 host

Expected results:
virt-inspector can obtain info from rhel7.3 guest image on rhel6.9 host


Additional info:
1.virt-inspector and virt-inspector2 can obtain info from rhel7.2 guest image on rhel6.9 host

1.1 # virt-inspector esx5.5-rhel7.2-x86_64-sda
linux rhel x86_64 7.2 (Red Hat Enterprise Linux Server release 7.2 (Maipo)) on /dev/rhel/root:
  Mountpoints:
    /dev/rhel/root                 /
    /dev/sda1                      /boot
    /dev/rhel/swap                 swap
  Filesystems:
    /dev/rhel/root:
      label: 
      UUID: e14eddc3-7787-41a2-9932-468d09f72284
      type: xfs
      content: linux-root
    /dev/rhel/swap:
      type: swap
    /dev/sda1:
      label: 
      UUID: 5a44170a-8bb9-4e92-a20f-0f57e979d903
      type: xfs
      content: linux-grub
  Modprobe aliases:
    scsi_hostadapter               virtio_blk
  Applications:
    GConf2 3.2.6
    ModemManager 1.1.0
  .......
  .......

1.2 # virt-inspector2 esx5.5-rhel7.2-x86_64-sda
<?xml version="1.0"?>
<operatingsystems>
  <operatingsystem>
    <root>/dev/rhel/root</root>
    <name>linux</name>
    <arch>x86_64</arch>
    <distro>rhel</distro>
    <product_name>Red Hat Enterprise Linux Server release 7.2 (Maipo)</product_name>
.....
.....
  </operatingsystem>
</operatingsystems>

Comment 1 Richard W.M. Jones 2017-01-16 08:56:47 UTC
This is actually the XFS thing which is known not to be supported:

mount -o ro /dev/rhel/root /sysroot/
[    2.585441] XFS (dm-1): bad version
[    2.586112] XFS (dm-1): SB validate failed

Comment 2 Richard W.M. Jones 2017-01-16 08:59:56 UTC
This is essentially the same problem as described in:
https://bugzilla.redhat.com/show_bug.cgi?id=1377702#c1

Comment 5 Pino Toscano 2017-01-16 13:22:08 UTC
Rich is right: the XFS version on the filesystem might be simply too new for the XFS driver in RHEL 6; you can check the version of the superblock in the image you created:

$ virt-rescue -a /dev/sda1
...
><rescue> xfs_db /dev/sda1
xfs_db> sb
xfs_db> p
...
versionnum = 0xb4b5
...

(then you can type "quit" to exit the "xfs_db>" prompt.) If the last digit there is 5 (like above), then it means the filesystem has V5 superblocks, which the RHEL kernel does not support (at most it can handle V4 IIRC); V5 superblocks require kernel >= 3.16.

See also http://oss.sgi.com/archives/xfs/2016-06/msg00182.html for more details.

Comment 6 Richard W.M. Jones 2017-01-23 14:06:04 UTC
This is not a bug in libguestfs, but a bug in the kernel, and we
cannot fix it in the kernel.  See this comment for a fuller
explanation:
https://bugzilla.redhat.com/show_bug.cgi?id=1377702#c1


Note You need to log in before you can comment on or make changes to this bug.