Bug 1413506 - There is no output when using "nodectl --version" command in cockpit terminal.
Summary: There is no output when using "nodectl --version" command in cockpit terminal.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: General
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.1.1
: 4.1
Assignee: Yuval Turgeman
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 08:49 UTC by Wei Wang
Modified: 2017-04-21 09:41 UTC (History)
9 users (show)

Fixed In Version: ovirt-node-ng-4.1.0-0.20170227.0.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:41:43 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
cshao: testing_ack+


Attachments (Terms of Use)
log files (329.69 KB, application/x-gzip)
2017-01-16 08:49 UTC, Wei Wang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71194 0 master MERGED nodectl: added --version info 2017-01-26 16:35:11 UTC
oVirt gerrit 72415 0 ovirt-4.1-snapshot MERGED nodectl: added --version info 2017-02-16 10:08:05 UTC
oVirt gerrit 72416 0 ovirt-4.1-pre MERGED nodectl: added --version info 2017-02-16 10:09:38 UTC
oVirt gerrit 72418 0 ovirt-4.1 MERGED nodectl: added --version info 2017-02-16 10:10:44 UTC

Description Wei Wang 2017-01-16 08:49:25 UTC
Created attachment 1241140 [details]
log files

Description of problem:
There is no output when using "nodectl --version" command in cockpit terminal.

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.1-0.20170112.0
cockpit-ovirt-dashboard-0.10.7-0.0.3.el7ev.noarch
cockpit-ws-126-1.el7.x86_64
imgbased-0.9.4-0.1.el7ev.noarch


How reproducible:
100%
Not Regression bug
Keywords: UI

Steps to Reproduce:
1. Install RHVH 4.1
2. Login cockpit website hostIP:9090 with root account
3. Go to "Tools"--->"Terminal"
4. Input "nodectl --version"


Actual results:
There is no output when using "nodectl --version" command in cockpit terminal.

Expected results:
Nodectl version should be displayed.


Additional info:
The issue also occur in rhvh shell console.

Comment 1 Wei Wang 2017-02-27 06:07:29 UTC
Test with redhat-virtualization-host-4.1-20170222.0, the result is: There is no output when using "nodectl --version" command in cockpit terminal. So the bug is exist, change status to ASSIGNED.

Comment 2 Red Hat Bugzilla Rules Engine 2017-02-27 06:07:37 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 3 Wei Wang 2017-03-10 08:48:05 UTC
Test version
redhat-virtualization-host-4.1-20170309.0
cockpit-ovirt-dashboard-0.10.7-0.0.15.el7ev.noarch
cockpit-ws-126-1.el7.x86_64
imgbased-0.9.17-0.1.el7ev.noarch

Test steps:
1. Install RHVH 4.1
2. Login cockpit website hostIP:9090 with root account
3. Go to "Tools"--->"Terminal"
4. Input "nodectl --version"

Result:
Nodectl version is displayed.
[root@dell-per730-34 ~]# nodectl --version
nodectl-4.1.0


The bug is fixed, change the status to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.