Bug 1413516 - Wrong message when memory resource converted from MB to KB in Resource Limits
Summary: Wrong message when memory resource converted from MB to KB in Resource Limits
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.4.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1457383 1506827 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 09:29 UTC by yufchang
Modified: 2020-07-16 09:07 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When editing existing memory limits for deployments and replication controllers specified in kB, the web console could incorrectly fail validation saying that the entered value is too small for the limit range. This only happened for kB, and not other memory units. The web console has been updated to correctly handle kB units when validating values against limit ranges.
Clone Of:
Environment:
Last Closed: 2017-04-12 19:09:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description yufchang 2017-01-16 09:29:37 UTC
Description of problem:
  Wrong message when memory resource converted from MB to kB in Resource Limits

 Version-Release number of selected component (if applicable):
 OpenShift Master:v3.4.0.39 (online version 3.4.0.12)
 Kubernetes Master:v1.4.0+776c994
 
 How reproducible:
 Always
        
 Steps to Reproduce:
 cat >> hello-deployment-1.yaml << EOF  
apiVersion: extensions/v1beta1
kind: Deployment
metadata:
  name: hello-openshift
spec:
  replicas: 4
  template:
    metadata:
      labels:
        app: hello-openshift
    spec:
      containers:
      - name: hello-openshift
        image: openshift/hello-openshift
        ports:
        - containerPort: 80
  strategy:
    rollingUpdate:
      maxSurge: 3
      maxUnavailable: 2
    type: RollingUpdate
EOF
 1.Create a project;
 2.oc create -f hello-deployment-1.yaml;
 3.Go to Applications -> Deployments -> <Deployment name> page -> Actions -> Set Resource Limits;
4. Set Memory to 900.9 MB;
5. Save;
6. Open Set Resource Limits again to check, and try to modify again.

Actual results:
5. Save successfully;
6. Display “900900kB”, but memory frame turn red and prompt error memory "can not be less than 250 MiB. Memory limit total for all containers is less than pod minimum (250 MiB)." Button "save" is not available.

Expected results:
900900kB is a valid value. No error message is displayed, button ‘save’ is available.

Additional info:
1. When  you input 900900000 kB, button ‘save’ become available,Maybe the unit shoud be B, not KB.
2. The convert between MiB to mB is correct.

Comment 2 Abhishek Gupta 2017-02-10 17:43:32 UTC
Assigning to Jessica to start with the frontend.

Comment 4 Troy Dawson 2017-02-13 22:33:10 UTC
This has been merged into ocp and is in OCP v3.5.0.20 or newer.

Comment 9 errata-xmlrpc 2017-04-12 19:09:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884

Comment 10 Samuel Padgett 2017-06-21 18:55:15 UTC
*** Bug 1457383 has been marked as a duplicate of this bug. ***

Comment 11 Jessica Forrester 2017-10-30 18:41:48 UTC
*** Bug 1506827 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.