Bug 141352 (IT_73458) - RHN Sat traceback registration.remaining_subscriptions invalid
Summary: RHN Sat traceback registration.remaining_subscriptions invalid
Status: CLOSED ERRATA
Alias: IT_73458
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Beth Nackashi
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 155572 156320
TreeView+ depends on / blocked
 
Reported: 2004-11-30 17:02 UTC by Matt Domsch
Modified: 2007-07-31 14:32 UTC (History)
4 users (show)

Fixed In Version: RHBA-2005-712
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 17:12:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
delete_old_systems.pl (2.73 KB, text/plain)
2004-11-30 17:03 UTC, Matt Domsch
no flags Details
rhn-traceback-on-system-register.txt (7.68 KB, text/plain)
2005-01-06 15:55 UTC, Matt Domsch
no flags Details
registration.py.patch (751 bytes, patch)
2005-02-18 21:56 UTC, Matt Domsch
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:712 qe-ready SHIPPED_LIVE up2date bug fix update 2005-09-28 04:00:00 UTC

Comment 1 Matt Domsch 2004-11-30 17:03:24 UTC
Created attachment 107634 [details]
delete_old_systems.pl

delete_old_systems.pl script which has been working fine for several months.

Comment 2 Matt Domsch 2005-01-06 15:55:10 UTC
Created attachment 109428 [details]
rhn-traceback-on-system-register.txt

I continue to see tracebacks resulting from
Exception while handling function registration.remaining_subscriptions
this time when someone tried registering a Fedora Core 3 server against the
satellite, which doesn't carry FC3.
Traceback message attached.

Comment 3 Matt Domsch 2005-02-18 21:56:24 UTC
Created attachment 111216 [details]
registration.py.patch

I believe this will fix it, applies to
/var/www/rhns/server/handlers/xmlrpc/registration.py, and restores this
function as called by the up2date clients.  It trivially returns -1 for
remaining_subscriptions, so it always succeeds (as it has for the clients
already), but avoids the RHN traceback messages being emailed to the RHN
satellite owner.

Comment 4 Mihai Ibanescu 2005-05-19 22:12:00 UTC
Matt, your fix is correct. But the client should have noticed the server does
not support that call and it shouldn't have called it. So, we'll have to look at
changing the client side code, probably.

Comment 6 Debbie McGrath 2005-06-08 14:28:10 UTC
This bug is considered CanFix for RHEL 3 U6 by RHN Engineering.

Comment 7 Debbie McGrath 2005-06-21 21:29:24 UTC
Dev & PM ACKs for U6

Comment 8 Adrian Likins 2005-06-22 16:37:55 UTC
client fix applied in 4.4.26

Comment 9 Beth Nackashi 2005-07-05 16:18:52 UTC
please provide a test plan

Comment 10 Adrian Likins 2005-07-11 16:43:24 UTC
Test plan.

To test this, you will need an old sattelite that does not support
registration.remaining_subscriptions. I belive 2.1 or early 3x sats
fall into this category. You will also need a new sat, 3.6 or 400
is fine.


Against a modern sat:

The account you are registering to needs to have extra entitlements
available for that system (aka, unused entitlements)

Point a current client (say, 4.4.28) at the sattelite. 

Run the gui registration (aka, just "up2date" or "up2date --register"
on a system with a proper X "DISPLAY" env setup)

after the first account screen (asking for username/password) there will
be a "activation key".  There will be an option for "use my existing
subscriptions". If this is not greyed out, and selectable as an option,
then it works. 

If it is greyed out, make sure you have approriate entitlements.

Then try using up all available entitlements, and running it again.
At this point, that option should be greyed out.


Against the old sat, go through the same steps, but against an old
sat. 

Running against an old sat that does not support
registration.remaining_subscriptions, that option should always
be available. 

Comment 11 Adrian Likins 2005-07-11 16:45:09 UTC
er, not "activation key" but an activation screen

Comment 13 Beth Nackashi 2005-07-17 20:30:45 UTC
status notes from Beth:
-retested on new satellite
-still in the midst of retesting on 2.1 satellite (rlx-1-04), but there are
10000 entitlements and I need to use them up.  I may upload a new cert with only
35 entitlements but this is Cliff's satellite so I'm going to put this off for now.

Comment 14 Beth Nackashi 2005-07-19 21:19:46 UTC
According to Cliff:  I don't need to verify that the registration process
doesn't crap out when a client attempts to register to a 2.1 satellite with no
remaining subscriptions because, as he puts it, if a customer's subscriptions
are used up they will be more concerned with buying more subscriptions than any
error message they get from up2date.

As such, I am moving this bug to PROD_READY based on the other tests I did on a
new satellite.

Comment 16 Red Hat Bugzilla 2005-09-28 17:12:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-712.html



Note You need to log in before you can comment on or make changes to this bug.