Bug 1413526 - glusterfind: After glusterfind pre command execution all temporary files and directories /usr/var/lib/misc/glusterfsd/glusterfind/<session>/<volume>/ should be removed
Summary: glusterfind: After glusterfind pre command execution all temporary files and...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterfind
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Milind Changire
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1413513 1417527
TreeView+ depends on / blocked
 
Reported: 2017-01-16 09:39 UTC by Milind Changire
Modified: 2017-05-30 18:38 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1413513
: 1417527 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:38:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Milind Changire 2017-01-16 09:39:19 UTC
+++ This bug was initially created as a clone of Bug #1413513 +++

Description of problem:

After a glusterfind pre query command execution all temporary files and
directories under /usr/var/lib/misc/glusterfsd/glusterfind/<session>/<volume>/
should be removed. 

It will end-up eating file system.

Version-Release number of selected component (if applicable):

glusterfs-3.8.4-11.el7rhgs.x86_64


How reproducible:

100%


Steps to Reproduce:
1. Create 2*2 distribute replicate volume
2. Do fuse mount and create some files and directories
3. create glusterfind session
4. do some file operation on mount point like create create file, remove files
5. run glusterfind pre command 

Actual results:

temporary files and directories under /usr/var/lib/misc/glusterfsd/glusterfind/<session>/<volume>/ are removed after glusterfind pre command

Expected results:


glusterfind should delete temporary files and directories under /usr/var/lib/misc/glusterfsd/glusterfind/<session>/<volume>/


Additional info:

Comment 1 Worker Ant 2017-01-16 10:03:58 UTC
REVIEW: http://review.gluster.org/16416 (tools/glusterfind: delete temporary folder) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)

Comment 2 Worker Ant 2017-01-30 05:27:29 UTC
COMMIT: https://review.gluster.org/16416 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit 355c1955039a39c820880be72fe77d4e74af0967
Author: Milind Changire <mchangir@redhat.com>
Date:   Mon Jan 16 15:27:09 2017 +0530

    tools/glusterfind: delete temporary folder
    
    Problem:
    Run specific temporary folder created under
    /usr/var/lib/misc/glusterfsd/glusterfind/<session>/<volume>/
    remains undeleted.
    
    Solution:
    Delete the temporary folder from all nodes.
    
    Change-Id: I0edaf868aebb01b15c489434bbb26fe853351384
    BUG: 1413526
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: https://review.gluster.org/16416
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>

Comment 3 Shyamsundar 2017-05-30 18:38:45 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.