Bug 1413537 - usr/bin/shutdown --no-wall argument ignored
Summary: usr/bin/shutdown --no-wall argument ignored
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 10:32 UTC by Michal Schorm
Modified: 2017-03-06 10:34 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-06 10:34:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Schorm 2017-01-16 10:32:53 UTC
When I use "shutdown -r --no-wall", the "--no-wall" argument is ignored.

Spotted in all Fedora versions.

Severity set to  high, since in some cases it can block user from use of "shutdown -r" (Failed to set wall message, ignoring: Connection timed out)



As I remember, it can be solved most of the times, calling this as a root. However, most of the times I really need this command, I can't log in as root. (Either don't know root credentials or "su" command freeze)

Comment 1 Zbigniew Jędrzejewski-Szmek 2017-01-28 02:57:41 UTC
Are you sure that the argument is ignored? I gave this some (light) testing now, and it seems to work just fine. This is with F25, but this code hasn't changed in ages.

Please note that --no-wall has no influence on whether shutdown comunicates with systemd-logind. It just means that systemd-logind will not broadcast the message, but it'll still be stored in systemd-logind, and can be retrieved e.g. using "loginctl show-session -p WallMessage".

I think this is just a misunderstanding.

Comment 2 Michal Schorm 2017-03-06 10:34:45 UTC
Hi,
under a fresh light of other bug reports, this could be caused by damaged systemd.

The issue appears only together with other bugs I reported.

I'll close this bug until I'll found out, what's wrong with my systemd and how to solve it.

Then it either won't appear again or I'll reopen it with new information.


Note You need to log in before you can comment on or make changes to this bug.