Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1413560 - wrong ldconfig-generated symlink for libopenblas
Summary: wrong ldconfig-generated symlink for libopenblas
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: R
Version: el6
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 12:05 UTC by Götz Waschk
Modified: 2017-01-16 19:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 19:02:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Götz Waschk 2017-01-16 12:05:03 UTC
Description of problem:
The upgrade from R-3.3.2-2.el6.x86_64 to R-3.3.2-3.el6.x86_64 includes a switch from external to internal blas library. However, as R's library directory is in ld.so's path, a symlink is generated:

# ls -l /usr/lib64/R/lib/*blas*            
lrwxrwxrwx. 1 root root 11 14. Dez 08:48 /usr/lib64/R/lib/libopenblas.so.0 -> libRblas.so

This can create problems with applications linked to libopenblas.so.0 which were meant to be linked to /usr/lib64/libopenblas.so.0:

[root@nafhh-herafitter ~]# ldd xfitter |grep -i blas
libopenblas.so.0 => /usr/lib64/R/lib/libopenblas.so.0 (0x000000324e800000)


Version-Release number of selected component (if applicable):
3.3.2-3.el6

How reproducible:
always


Steps to Reproduce:
1. Install R-3.3.2-2.el6.x86_64
2. upgrade to R-3.3.2-3.el6.x86_64
3. run ldd on any program linked to libopenblas.so.0

Actual results:
/usr/lib64/R/libopenblas.so.0

Expected results:
/usr/lib64/libopenblas.so.0


Additional info:
The symlink /usr/lib64/R/lib/libopenblas.so.0 is not automatically removed on upgrade or uninstallation of the R-core package.

Comment 1 Tom "spot" Callaway 2017-01-16 19:02:48 UTC
Okay, so that is a relic of R-3.3.2-2.el6.x86_64. The libopenblas symlink was created because in that package, libRblas.so was a symlink directly to libopenblas.so.0. ldconfig made the additional /usr/lib64/R/lib/libopenblas.so.0 symlink.

If you install just R-3.3.2-3.el6.x86_64 (not upgrade from -2), you should not generate that file. No one else should generate it going forward. You should be safe to simply remove /usr/lib64/R/lib/libopenblas.so.0 manually.

I'm a bit reluctant to add a scriplet to remove that file, since technically, R didn't own it to start with, and it only got created when -2 was installed (and no one should be installing -2 anymore)... thus, I'm closing this WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.