Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1413577 - Extraneous characters inserted into gdm password box
Summary: Extraneous characters inserted into gdm password box
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 12:39 UTC by Don Swaner
Modified: 2017-01-22 01:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-22 01:00:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Don Swaner 2017-01-16 12:39:00 UTC
Description of problem:
At the gdm screen, there is intermittent freezing. Extraneous characters are inserted into password text box upon entering initial character of password.  This is likely related to nouveau X11 driver.  My video hardware: 
NVIDIA GeForce 6150 LE

Version-Release number of selected component (if applicable):
gdm-3.22.1-1.fc25.x86_64
xorg-x11-drv-nouveau-1.0.13-1.fc25.x86_64
mesa-dri-drivers-13.0.3-1.fc25.x86_64

How reproducible:
Always

Steps to Reproduce:
1.  Boot with nouveau.noaccel=1 (booting without causes intermittent aborts)
2.  At gdm screen, move mouse pointer.
3.  Select login user
4.  At password prompt, press first letter of password.

Actual results:
(At least for a couple of minutes), there is lots of intermittent freezing of mouse pointer, and password entry.  [Press the first letter of your password.]
*TWO* dots appear in the password text box.  If you do not backspace over the two dots, and start over again, the password will fail.

Expected results:
No freezing.  No extraneous characters inserted.

Additional info:
I'm having numerous problems apparently due to nouveau X11 driver (acceleration) and my video hardware: invisible mouse pointer (https://bugzilla.redhat.com/show_bug.cgi?id=1413407); aborts (https://bugzilla.redhat.com/show_bug.cgi?id=1398936 ...); and other problems (https://bugzilla.redhat.com/show_bug.cgi?id=1408881).

Comment 1 Don Swaner 2017-01-22 01:00:16 UTC
10 year old PC.


Note You need to log in before you can comment on or make changes to this bug.