Bug 1413609 - Not listing bash scripts from $HOME/bin
Summary: Not listing bash scripts from $HOME/bin
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bash
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Siteshwar Vashisht
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 13:46 UTC by Pavlin Georgiev
Modified: 2017-01-24 09:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 09:38:47 UTC
Type: Bug


Attachments (Terms of Use)
bash_profile for user test on Fedora 25 (194 bytes, text/plain)
2017-01-16 13:46 UTC, Pavlin Georgiev
no flags Details

Description Pavlin Georgiev 2017-01-16 13:46:42 UTC
Created attachment 1241240 [details]
bash_profile for user test on Fedora 25

Description of the problem:
Not listing bash scripts from $HOME/bin

Machine: HP xw4600 Workstation
OS: Fedora 25
Kernel: 4.9.3-200.fc25.x86_64

Version-Release number of selected component (if applicable):
bash-4.3.43-4.fc25.x86_64
gnome-shell-3.22.2-2.fc25.x86_64


How reproducible:
Always

Steps to Reproduce:
0. There is a bash script in /home/test/bin/testing_loop.sh
1. Log in as user test LOCALLY, not remotely.
2. Open a terminal.
3. Try to type the name of the script testing[TAB]
The bug appears. The auto completion does not find the bash script.
4. Type the script's name without its full path: testing_loop.sh
The script is not found.

Actual results:
The bash shell does not find the bash script which is in $HOME/bin

Expected results:
The bash shell starts any bash script which is in $HOME/bin, which has execution permissions.

Additional info:
User: test      User ID: 1000

Script: -rwxrwxr-x 1 test test 1985 Jan 16 11:15 /home/test/bin/testing_loop.sh

Comment 1 Kamil Dudka 2017-01-16 14:21:11 UTC
What is the actual contents of the PATH environment variable?

$ echo $PATH

How are you confirming that your bash_profile script is actually used?

Does it work after you source it manually?

Which terminal are you using?

Do you know which parameters the terminal starts bash with?

Note that according to bash(1) man page ~/.bash_profile is executed for login shells only...

Comment 2 Pavlin Georgiev 2017-01-24 09:38:47 UTC
Excuses for my late response.

Now, when I log in locally, not via SSH, everything is fine.

Not sure what was the reason, but now the bug does not appear.
I checked the kernel version, bash, and gnome-shell and they have the same versions:
kernel-4.9.3-200.fc25.x86_64
bash-4.3.43-4.fc25.x86_64
gnome-shell-3.22.2-2.fc25.x86_64

We can close this case.


Note You need to log in before you can comment on or make changes to this bug.