Bug 141361 - text too small
text too small
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
Mike MacKenzie
https://bugzilla.redhat.com/beta/show...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 13:00 EST by Felix Miata
Modified: 2013-06-23 22:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 638726 (view as bug list)
Environment:
Last Closed: 2008-12-01 11:01:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
1400x1050 screenshot - mozilla/chatzilla 22px default monospace & proportional (134.59 KB, image/png)
2004-11-30 15:15 EST, Felix Miata
no flags Details
screenshot 1400x1050 120 DPI 22px Firefox/SeaMonkey defaults (171.65 KB, image/png)
2005-11-12 13:12 EST, Felix Miata
no flags Details
screenshot 1400x1050 120 DPI 22px defaults FF/SM zoomed 2 steps (150%) (223.04 KB, image/png)
2005-11-12 13:12 EST, Felix Miata
no flags Details
testcase (6.55 KB, text/html)
2006-08-30 11:14 EDT, Felix Miata
no flags Details
testcase (6.33 KB, text/html)
2006-08-30 11:17 EDT, Felix Miata
no flags Details
16px default 1400x1050x96DPI screenshot (87.47 KB, image/png)
2006-08-30 11:23 EDT, Felix Miata
no flags Details
user stylesheet that makes bugzilla usable (38.32 KB, text/css)
2006-08-30 13:37 EDT, Felix Miata
no flags Details
20px default 1600x1200x120DPI screenshot (183.12 KB, image/gif)
2007-07-24 11:37 EDT, Felix Miata
no flags Details
24px default 1920x1440x144DPI screenshot (291.43 KB, image/jpeg)
2007-11-06 20:25 EST, Felix Miata
no flags Details
Screenshot Firefox2 at 100% zoom, note the eensy weensy teeny tiny size of the comment text (144.29 KB, image/png)
2008-10-07 09:56 EDT, David Spalding
no flags Details

  None (edit)
Description Felix Miata 2004-11-30 13:00:05 EST
Description of problem:
Most text is too small, notably comments already posted to the bug. The
disparity between largest and smallest is so vast that browser zoom is unsuited
to making the page usable. Only a browser minimum font size or user stylesheet
can make the page usable, and then marginally so.

How reproducible:
100%

Steps to Reproduce:
1-Open the URL
  
Actual results:
1-text painfully small
2-page too hard to use

Expected results:
1-comfortable to read size text (mostly my default)
2-no text is sized in px

Additional info:
I don't recall this being a problem when I reported bugs or commented in bugs
here a year or so ago. From the several stylesheets applicable to the page, I
have collected the font sizing rules & quantities as follows:
font-size: 9px;		1
font-size: 10px;	7
font-size: 11px;	1
font-size: 12px;	3
font-size: 13px;	3 (includes <pre> used for comments)
font-size: 14px;	1
font-size: 15px;	1
font-size: 16px;	1
font-size: 17px;	1
font-size: 18px;	1
font-size: 75%;		2
font-size: 85%;		2
font-size: 100%;	1
font-size: 255%;	2
font-size: 300%;	2
font-size: 0.75em;	1
font-size: 0.8em;	2
font-size: 0.9em;	1
font-size: 1em;		1
font-size: 1.2em;	1
font-size: 2.3em;	1
font-size: xx-small;	1
font-size: x-small;	13
font-size: small;	26
font-size: smaller;	1
font-size: medium;	4
font-size: large;	2
font-size: x-large;	1

Total smaller:		68 
Total equal:		6
Total larger:		4

Equal is defined as my browser default setting: 20px in Mozilla and Firefox

More discussion at: http://members.ij.net/mrmazda/auth/defaultsize.html
Comment 1 Felix Miata 2004-11-30 15:15:26 EST
Created attachment 107648 [details]
1400x1050 screenshot - mozilla/chatzilla 22px default monospace & proportional
Comment 2 David Lawrence 2004-12-01 11:17:45 EST
You screenshot is of the older production BZ. We are currently working on new
beta that is accessible to the public as well. Can you verify that this is still
an issue with the new BZ as well and comment here?

https://bugzilla.redhat.com/beta

Thanks
Comment 3 Felix Miata 2004-12-01 12:46:20 EST
The beta fonts are equally microscopic. The layout on first glance seems
slightly improved, though it is hard to tell without being able to read it all. :-(

The css called by each, according to the web developer extension for mozilla,
consists of 10 files each. When I wget both sets and compare the directory
listings, the timestamps and byte counts match perfectly, though one file does
have a different name, global.css vs. globalbeta.css. Diff on these last two
returns null.

Oh, and in comment 0, s/ser default setting: 20px/ser default setting: 22px/
Comment 4 Felix Miata 2005-11-12 13:12:25 EST
Created attachment 120987 [details]
screenshot 1400x1050 120 DPI 22px Firefox/SeaMonkey defaults

Current version is still dismal.
Comment 5 Felix Miata 2005-11-12 13:12:51 EST
Created attachment 120988 [details]
screenshot 1400x1050 120 DPI 22px defaults FF/SM zoomed 2 steps (150%)

Current version handles zoom poorly.
Comment 6 Felix Miata 2006-08-30 11:14:27 EDT
Created attachment 135215 [details]
testcase
Comment 7 Felix Miata 2006-08-30 11:17:37 EDT
Created attachment 135216 [details]
testcase
Comment 8 Felix Miata 2006-08-30 11:23:05 EDT
Created attachment 135218 [details]
16px default 1400x1050x96DPI screenshot

still quite bad with latest CSS:
 7-25-06  6,264 bugzilla.css
 8-15-06 31,611 custom.css
 6-16-06  4,640 global.css
 6-05-06 15,622 headings.css
 6-28-06    953 master.css
 7-31-06  8,596 middlenav.css
 7-12-06 10,260 navigation.css
 6-29-06 16,225 pagelayout.css
 5-01-06 11,126 tables.css
11-08-05  1,688 truthhappens.css
 6-28-06  3,304 www-gis.css
Comment 9 Felix Miata 2006-08-30 13:37:50 EDT
Created attachment 135226 [details]
user stylesheet that makes bugzilla usable

Took more than 4 hours to make this from the over 112k of site CSS. The
redundance in the site styles is incredible. It's far from perfect, but far
more usable than the site styles.
Comment 10 Felix Miata 2007-07-24 11:37:13 EDT
Created attachment 159860 [details]
20px default 1600x1200x120DPI screenshot
Comment 11 David Lawrence 2007-11-02 15:28:23 EDT
Fonts have been updated lately and should now be more readable. Reopen this bug
if the problem persists.
Comment 12 Felix Miata 2007-11-06 20:25:40 EST
Created attachment 249811 [details]
24px default 1920x1440x144DPI screenshot

I can see no material change.
Comment 13 David Lawrence 2008-09-16 12:51:41 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 14 Felix Miata 2008-09-16 16:49:23 EDT
It's much improved, but not fixed. I believe a a patch similar to the following would fix most, if not all, remaining problems:

--- standardglobal0.css	2008-09-09 11:29:20.000000000 -0400
+++ standardglobal.css	2008-09-16 16:47:56.000000000 -0400
@@ -29,8 +29,8 @@
         background: #fff url("global/body-back.gif") repeat-x;
     }
     body, td, th, input {
-        font-family: Verdana, sans-serif;
-        font-size: small;
+        font-family: /*Verdana,*/ sans-serif; /* Verdana is not a FOSS font!
+	See also: http://www.xs4all.nl/~sbpoley/webmatters/verdana.html */
     }    
 /* global (end) */
 
@@ -41,12 +41,12 @@
     }
 
     #header form {
-        font-size: 85%;
+        font-size: small;
         display: inline;
     }
 
     #header .links {
-        font-size: 85%;
+        font-size: small;
         border-left: 1px solid silver;
         border-right: 1px solid silver;
         border-bottom: 1px solid silver;
@@ -214,7 +214,7 @@
     float: right;
     border: 1px solid black;
     padding: 1ex;
-    font-size: 80%;
+    font-size: small;
 }
 
 #docslinks h2 {
--- contribglobal0.css	2008-08-13 14:12:42.000000000 -0400
+++ contribglobal.css	2008-09-16 16:41:10.000000000 -0400
@@ -57,7 +57,7 @@
     margin-bottom: 10px;
     border: 1px solid #8C8F91;
     padding: 10px;
-    font-size: 10pt;
+    font-size: medium;
     -moz-border-radius: 5px;
 }
 
@@ -103,7 +103,7 @@
 
 #attachment-list {
     border: 2px solid #c8c8ba;
-    font-size: 9pt;
+    font-size: small;
 }
 
 #attachment-list th {
@@ -149,13 +149,13 @@
 }
 
 #knob-buttons a {
-    font-size: 10pt;
+    font-size: small;
 }
 
 /* comments */
 
 #comments th {
-    font-size: 9pt;
+    font-size: small;
     font-weight: bold;
     padding-top: 5px;
     padding-right: 5px;
@@ -181,7 +181,7 @@
     border-style: solid;
     border-color: #c8c8ba;
     padding: 5px;
-    font-size: 9pt;
+    font-size: small;
 }
 
 .bz_first_comment {
@@ -214,7 +214,7 @@
     background: #8C8F91;
     color: #ffffff;
     width: 100%;
-    font-size: 9pt;
+    font-size: small;
     -moz-border-radius: 5px;
 }
Comment 15 David Lawrence 2008-09-18 14:38:34 EDT
Fixes should appear in the next update today or tomorrow.

Thanks
Dave
Comment 16 David Spalding 2008-10-07 09:56:25 EDT
Created attachment 319641 [details]
Screenshot Firefox2 at 100% zoom, note the eensy weensy teeny tiny size of the comment text

Re-opening the bug. 

I learned years ago that it's rarely a good idea to define font sizes by PT in CSS. Generally, if you consider 10pt to be 100%, then "9pt" should be 90%, "12pt" 120%, etc. Setting PT size prevents browsers (well, Mozilla-based ones)
from sizing the text with zooming or "preferred font size" settings, so the 
user is stuck with your font size, or changing their desktop resolution. 

If I read the CSS here correctly, we are setting comment text to 
"small," and 9pt as well. Years ago, major sites like CNN.COM adopted 8pt and
9pt sans-serif font varieties, which probably looked fine on someone's
1024x768 17" monitor. Looked terrible at 1400x1050 on 14", or 1600x1200
on a 20", rendering their site an eyesore and difficult to read. 

My expertise in CSS is a bit rusty, but I can assure you that FF2 is unable
to size the comment text in the current version of bugzilla.redhat.com.

An earlier attachment quoted a usability source asserting that paragraph text
should not be smaller that 10pt. I concur. In the world of Web, users are on
different browsers, different desktop resolutions, different sized monitors. 
Locking down paragraph text area to a predetermined (and unchangeable) font 
size is detrimental for readability. Please remove references to PT size in
any paragraph. 

Again, please remove all point-size restrictions to comment and other paragraph
text areas. Change "small" to "medium" for usability. TIA.
Comment 18 David Lawrence 2008-12-01 11:01:41 EST
The font size for comments have been changed to medium. Please reopen this issue if the problem persists.
Comment 19 David Spalding 2008-12-01 14:57:54 EST
Looks great!
Comment 20 Felix Miata 2008-12-09 00:50:59 EST
It's still not completely fixed. Size on body and #bugzilla-body is still set to small. That makes most text on buglist pages smaller than user preferred size. In most cases, there's no respectable basis to make that arbitrary imposition on users, though maybe because buglist pages have so much data to show it needs to be that way to get a reasonable fit without horizontal scroll.

It's also preferring Verdana to the user's preferred sans-serif. There's no rational basis to prefer a non-FOSS font on this site.

Note You need to log in before you can comment on or make changes to this bug.