Bug 1413612 - "Customer portal credentials are not available" when logged out due to a timeout, re-logged and tried to kick off a deployment
Summary: "Customer portal credentials are not available" when logged out due to a time...
Keywords:
Status: NEW
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.2
Assignee: John Matthews
QA Contact: Sudhir Mallamprabhakara
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 13:52 UTC by Antonin Pagac
Modified: 2017-01-20 21:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Antonin Pagac 2017-01-16 13:52:48 UTC
Description of problem:
During my storage testing, I have prepared a deployment of RHV+CFME in the UI. I filled-in all information required, including subscription credentials and selecting SMA. I went all the way up to the Installation Review screen. I then left my deployment in that state for about an hour. Then, I tried to continue, but due to a timeout I was logged out. So I logged in, clicked on my deployment, clicked on Review and clicked on the Deploy button. Instead of a deployment being kicked off, this error appeared:

' {"displayMessage":"Customer portal credentials are not available.","errors":["Customer portal credentials are not available."]}'

In the Installation Review screen, I can see all my subscriptions present, as I defined them before. When clicking on a Subscriptions section I'm however asked to log-in again.

It is confusing to see all the subscriptions present in Installation Review screen and at the same time being unable to continue due to missing customer portal credentials. Also, the format of the error message is not user-friendly.

Version-Release number of selected component (if applicable):
QCI-1.1-RHEL-7-20170112.t.0

How reproducible:
Unsure; happened to me once

Steps to Reproduce:
1. Define a deployment up to the Installation Review screen; don't kick it off
2. Leave it be for an hour, to get logged off
3. Log in again, go to QCI -> Deployments, click on your deployment, click on Review
4. After a successful validation notice the subscriptions being present
5. Click on the Deploy button
6. Error appears

Actual results:
Error appears; cannot kick off the deployment

Expected results:
We should at least display more user-friendly error message. Instead of the error listed above, there could be just:

"Customer portal credentials are not available."

In ideal case, we should detect that the credentials are not available when validating the deployment (after user clicks on Review) and possibly don't show subscriptions on the Installation review screen, when we can't get to them.

Additional info:
When I logged in to customer portal again, I was able to kick off the deployment successfully.


Note You need to log in before you can comment on or make changes to this bug.