Bug 1413644 - Unsupported encoding iso-8859-2 / windows-1251 / ...
Summary: Unsupported encoding iso-8859-2 / windows-1251 / ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 15:29 UTC by Miro Hrončok
Modified: 2017-09-19 21:19 UTC (History)
2 users (show)

Fixed In Version: chromium-60.0.3112.113-1.fc26 chromium-60.0.3112.113-1.fc25 chromium-60.0.3112.113-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-02 22:25:12 UTC
Type: Bug


Attachments (Terms of Use)
Reproducer (61 bytes, application/xml)
2017-01-16 15:29 UTC, Miro Hrončok
no flags Details

Description Miro Hrončok 2017-01-16 15:29:38 UTC
Created attachment 1241294 [details]
Reproducer

Description of problem:
The XML parser in Chromium fails with XML files with some non-utf encodings including iso-8859-2 and windows-1251.

Version-Release number of selected component (if applicable):
55.0.2883.87-1.fc25

How reproducible:
Easy.

Steps to Reproduce:
1. Open http://xpoint.ru/ in Chromium

or

2. Open http://www.fis.cvut.cz/ in Chromium

or

3. Open attached test.xml in Chromium 


Actual results:
1. error on line 1 at column 44: Unsupported encoding windows-1251
2. error on line 1 at column 42: Unsupported encoding iso-8859-2
3. error on line 1 at column 42: Unsupported encoding iso-8859-2

Expected results:
No XML errors

Additional info:
It works in Google Chrome and Firefox. Upstream issue was closed years ago because the actual build was blamed: https://bugs.chromium.org/p/chromium/issues/detail?id=28748

Quote from there:

> This does not happen with Google Chrome. Google Chrome uses libxml that is
> configured to use ICU's character encoding converter.  
> 
> Apparently, some Linux distributions have Chromium built with system libxml
> (that uses iconv by default). It's still strange because iconv in glibc
> does support ISO-8859-15 and windows-1251.  (check the output of 'iconv -l'
> and see if those two charsets are listed). 
> 
> Those with this problem have to contact their distribution builders about
> this issue.

Comment 1 Tom "spot" Callaway 2017-08-29 11:49:44 UTC
I cannot reproduce these errors with chromium-60.0.3112.113. I'm going to close this bug against that update, if you can reproduce, please reopen.

Comment 2 Fedora Update System 2017-09-01 03:49:32 UTC
chromium-60.0.3112.113-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-8f80d01c29

Comment 3 Fedora Update System 2017-09-01 11:54:06 UTC
chromium-60.0.3112.113-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e11dade5d0

Comment 4 Fedora Update System 2017-09-01 12:53:37 UTC
chromium-60.0.3112.113-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c708c044e3

Comment 5 Fedora Update System 2017-09-02 22:25:12 UTC
chromium-60.0.3112.113-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2017-09-10 04:50:32 UTC
chromium-60.0.3112.113-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2017-09-19 21:19:59 UTC
chromium-60.0.3112.113-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.