Bug 1413690 - bonding parameters are removed each time an undercloud operation is executed
Summary: bonding parameters are removed each time an undercloud operation is executed
Keywords:
Status: CLOSED DUPLICATE of bug 1385041
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 16:48 UTC by David Hill
Modified: 2018-12-12 14:20 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-03 17:50:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1385041 None NEW [RFE] Undercloud Should Support Provisioning Via Bonded Interface 2019-07-01 06:10:27 UTC
Red Hat Knowledge Base (Solution) 2895461 None None None 2017-07-13 10:16:19 UTC

Description David Hill 2017-01-16 16:48:11 UTC
Description of problem:

After an update or fresh install, the bond mode defaults to round-robin which causes configured port channel  in  switches to go down. 

Would it be possible to add a bonding configuration within the undercloud.conf file in order to prevent this from happening?

IE:

Each time the following command are executed:
 openstack undercloud install
 openstack undercloud upgrade

The following line disappear:
BONDING_OPTS="mode=802.3ad ad_select=bandwidth lacp_rate=fast xmit_hash_policy=layer2+3 miimon=100"


Version-Release number of selected component (if applicable):
All

How reproducible:
Always

Steps to Reproduce:
1. Configure bond
2. Run openstack undercloud install

Actual results:
Bond breaks

Expected results:
Bond shouldn't break

Additional info:

Comment 1 Benjamin Schmaus 2017-01-30 13:17:11 UTC
Any update on this and when and if we might see fixed?

Comment 5 James Slagle 2017-05-30 21:40:49 UTC
(In reply to David Hill from comment #0)
> Description of problem:
> 
> After an update or fresh install, the bond mode defaults to round-robin
> which causes configured port channel  in  switches to go down. 
> 
> Would it be possible to add a bonding configuration within the
> undercloud.conf file in order to prevent this from happening?
> 
> IE:
> 
> Each time the following command are executed:
>  openstack undercloud install
>  openstack undercloud upgrade
> 
> The following line disappear:
> BONDING_OPTS="mode=802.3ad ad_select=bandwidth lacp_rate=fast
> xmit_hash_policy=layer2+3 miimon=100"

From what file does this line disappear? Is it an interface config file under /etc/sysconfig/network-scripts? If so, is os-net-config managing that interface?

If it is, then it's expected behavior that os-net-config regenerates those files when the undercloud commands are run.

How is the line getting there in the first place? I'm not sure it's even possible to represent these bonding options for an undercloud install.

Comment 9 Bob Fournier 2017-08-01 14:55:20 UTC
This is as expected as the undercloud does not support bonding - see the future feature request here: https://bugzilla.redhat.com/show_bug.cgi?id=1385041.  

The undercloud is expecting that there exists a single interface used for provisioning.

Comment 10 Bob Fournier 2017-09-03 17:50:58 UTC
Marking this as a duplicate to the bug tracking bonding in the undercloud so that updates and status can be kept on one place.

*** This bug has been marked as a duplicate of bug 1385041 ***


Note You need to log in before you can comment on or make changes to this bug.