Bug 1413709 - SELinux is preventing gdm-session-wor from 'view' accesses on the key Unknown.
Summary: SELinux is preventing gdm-session-wor from 'view' accesses on the key Unknown.
Keywords:
Status: CLOSED DUPLICATE of bug 1378297
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:de5cb7ba80537bf65dceea7f2ae...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 18:35 UTC by Adam Williamson
Modified: 2017-01-16 18:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 18:59:04 UTC
Type: ---


Attachments (Terms of Use)

Description Adam Williamson 2017-01-16 18:35:41 UTC
Description of problem:
Happened during a straightforward 'boot and run a default install' test on Fedora-Workstation-Live-x86_64-Rawhide-20170115.n.0.iso .
SELinux is preventing gdm-session-wor from 'view' accesses on the key Unknown.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gdm-session-wor should be allowed view access on the Unknown key by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gdm-session-wor' --raw | audit2allow -M my-gdmsessionwor
# semodule -X 300 -i my-gdmsessionwor.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:system_r:kernel_t:s0
Target Objects                Unknown [ key ]
Source                        gdm-session-wor
Source Path                   gdm-session-wor
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-233.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.10.0-0.rc3.git4.1.fc26.x86_64 #1
                              SMP Fri Jan 13 20:43:53 UTC 2017 x86_64 x86_64
Alert Count                   6
First Seen                    2017-01-16 17:56:28 EST
Last Seen                     2017-01-16 17:56:28 EST
Local ID                      734f9e4d-5edd-4b63-aef1-29856f952691

Raw Audit Messages
type=AVC msg=audit(1484607388.648:137): avc:  denied  { view } for  pid=1347 comm="gdm-session-wor" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:kernel_t:s0 tclass=key permissive=0


Hash: gdm-session-wor,xdm_t,kernel_t,key,view

Version-Release number of selected component:
selinux-policy-3.13.1-233.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.0
hashmarkername: setroubleshoot
kernel:         4.10.0-0.rc3.git4.1.fc26.x86_64
type:           libreport

Potential duplicate: bug 1389874

Comment 1 Adam Williamson 2017-01-16 18:59:04 UTC

*** This bug has been marked as a duplicate of bug 1378297 ***


Note You need to log in before you can comment on or make changes to this bug.