Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1413714 - Upgrading metrics fails
Summary: Upgrading metrics fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 18:51 UTC by Wesley Hearn
Modified: 2017-02-10 14:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-10 14:52:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
deploy log (3.46 KB, text/plain)
2017-01-16 18:51 UTC, Wesley Hearn
no flags Details

Description Wesley Hearn 2017-01-16 18:51:42 UTC
Created attachment 1241365 [details]
deploy log

Description of problem:
Trying to upgrade metrics from 3.3.0 to 3.4.0 using MODE=refresh, the deploy fails with an error saying it could not change some fields. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install metrics 3.3.0 on a 3.3.X cluster
2. Upgrade cluster to 3.4.0
3. Try upgrading metrics by passing MODE=refresh to the metrics template.

Actual results:
The Pod "metrics-deployer-abnda" is invalid: spec: Forbidden: pod updates may not change fields other than `containers[*].image` or `spec.activeDeadlineSeconds`


Expected results:


Additional info:

Comment 1 Matt Wringe 2017-01-16 18:53:43 UTC
What exact command are you using to do the update? Is it being run by the deployer SA or the user who is currently logged into oc?

Comment 2 Wesley Hearn 2017-01-16 20:35:31 UTC
It is being done through ansible as the cluster admin user.

The role is here https://github.com/openshift/openshift-tools/blob/stg/ansible/roles/openshift_metrics/tasks/main.yml

The only change is at line 92 I added "MODE: refresh" to the list.

Comment 3 Peng Li 2017-01-17 01:42:13 UTC
the error log is similar to https://bugzilla.redhat.com/show_bug.cgi?id=1381336

Comment 6 Matt Wringe 2017-02-09 23:26:36 UTC
@sdobson: please do not reassign to the metrics component. This is an error in how the installer is installing metrics. It needs to be done using the right service account.

The metrics team is not responsible for how ansible is installing metrics in 3.4

Comment 7 Scott Dodson 2017-02-10 02:49:32 UTC
Matt Woodson, Is still relevant to the method you're currently using to upgrade metrics? It looks like the suggestion in comment 5 needs to be applied to your playbooks if so.

Comment 9 Scott Dodson 2017-02-10 14:52:22 UTC
closing not a bug because this problem does not appear to be in openshift-ansible but in a separate repo


Note You need to log in before you can comment on or make changes to this bug.