Bug 1413722 - gnome-shell (X11) freezes with nouveau driver and acceleration ON
Summary: gnome-shell (X11) freezes with nouveau driver and acceleration ON
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 19:33 UTC by Don Swaner
Modified: 2017-01-22 00:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-22 00:59:27 UTC
Type: Bug


Attachments (Terms of Use)
journal listing around time of gnome-shell freeze (1.18 MB, text/plain)
2017-01-16 19:33 UTC, Don Swaner
no flags Details

Description Don Swaner 2017-01-16 19:33:18 UTC
Created attachment 1241377 [details]
journal  listing around time of gnome-shell freeze

Description of problem:
If I boot with nouveau acceleration ON, and log into the Gnome Classic desktop, sometimes the desktop freezes for some minutes.  In this instance, eventually the desktop became completely "irrational" responding inappropriately to mouse clicks - displaying torn partial windows (the "wrong" windows at that), and displaying "stringy garbage" in places.  Switching to console 3, "top" showed gnome-shell using 99% cpu (during the freeze).  I have evolution prompt for an email  password.  With acceleration ON the grayed out evolution screen behind the prompt box displayed up-side-down.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-1.0.13-1.fc25.x86_64
gnome-shell-3.22.2-2.fc25.x86_64

How reproducible:
Intermittent.  (I avoid running with acceleration ON because of various problems, including aborts.)

Steps to Reproduce:
1.  Boot with nouveau acceleration ON
2.  Log into Gnome Classic desktop

Actual results:
Desktop soon freezes, except for the mouse pointer.  Later, the desktop "unfreezes", but may become completely irrational.

Expected results:
Desktop does not freeze and performs as expected.

Additional info:
Video hardware: NVIDIA GeForce 6150 LE
With acceleration ON, sometimes there will be an abort starting up the gnome desktop.  I'm having several other problems with acceleration turned ON (https://bugzilla.redhat.com/show_bug.cgi?id=1408881).

Comment 1 Don Swaner 2017-01-22 00:59:27 UTC
10 year old PC.


Note You need to log in before you can comment on or make changes to this bug.