Bug 141373 - variables SYSLOGOPTS and NETLOGOPTS incorrectly referenced in /etc/rc.d/init.d/netdump
Summary: variables SYSLOGOPTS and NETLOGOPTS incorrectly referenced in /etc/rc.d/init....
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: netdump (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Neil Horman
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-30 19:01 UTC by bjorn l.
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 0.7.14-1.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 16:40:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bjorn l. 2004-11-30 19:01:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:

In line 250:
   if [ -n $SYSLOGOPTS ] || [ -n $NETLOGOPTS ] ; then

always returns true.

You might have intended:
   if [ -n "$SYSLOGOPTS" ] || [ -n "$NETLOGOPTS" ] ; then

It's a minor issue, because the only side effect is that
the netconsole module is always loaded.  But if you wanted
that, the if statement is irrelevant.


Version-Release number of selected component (if applicable):
netdump-0.7.0-1

How reproducible:
Always

Steps to Reproduce:
1. Check the /etc/rc.d/init.d/netdump script
2.
3.
    

Additional info:

Comment 1 Dave Anderson 2004-11-30 20:07:12 UTC
Thanks...  

Also, if you set NETLOGADDR=NONE, you get the desired behaviour -- but
only because the unintended insmod of the netconsole module fails.





Comment 2 Neil Horman 2006-06-26 16:40:47 UTC
This is already fixed in furute versions of fedora and RHEL


Note You need to log in before you can comment on or make changes to this bug.