Bug 1413738 - Dell Precision 7510 trackpoint speed after update to 4.9.3 high [NEEDINFO]
Summary: Dell Precision 7510 trackpoint speed after update to 4.9.3 high
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 20:40 UTC by robert.gartler
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-28 17:11:16 UTC
Type: Bug
jforbes: needinfo?


Attachments (Terms of Use)

Description robert.gartler 2017-01-16 20:40:52 UTC
Description of problem:
After upgrading the kernel to 4.9.3 (from 4.8.16 - last update was performed on the 12th of january) today, the trackpoint speed of my dell precision 7510 is incredibly high (and therefor unusable). 
I tried to change the speed with xinput, but that does not have an effect.
The speed of an USB mouse of the touchpad is ok.

I even tried to set it up from scratch again on a new harddisk. Initially it is fine, but after doing an dnf update, I get the same result.

That is what xinput tells me:
xinput list-props "AlpsPS/2 ALPS DualPoint Stick"

Device 'AlpsPS/2 ALPS DualPoint Stick':
Device Enabled (141):	1
Coordinate Transformation Matrix (143):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Accel Speed (286):	0.000010
libinput Accel Speed Default (287):	0.000000
libinput Accel Profiles Available (301):	1, 1
libinput Accel Profile Enabled (302):	1, 0
libinput Accel Profile Enabled Default (303):	1, 0
libinput Natural Scrolling Enabled (288):	0
libinput Natural Scrolling Enabled Default (289):	0
libinput Send Events Modes Available (263):	1, 0
libinput Send Events Mode Enabled (264):	0, 0
libinput Send Events Mode Enabled Default (265):	0, 0
libinput Left Handed Enabled (290):	0
libinput Left Handed Enabled Default (291):	0
libinput Scroll Methods Available (292):	0, 0, 1
libinput Scroll Method Enabled (293):	0, 0, 1
libinput Scroll Method Enabled Default (294):	0, 0, 1
libinput Button Scrolling Button (304):	2
libinput Button Scrolling Button Default (305):	2
libinput Middle Emulation Enabled (295):	0
libinput Middle Emulation Enabled Default (296):	0
Device Node (266):	"/dev/input/event5"
Device Product ID (267):	2, 8
libinput Drag Lock Buttons (299):	<no items>
libinput Horizontal Scroll Enabled (300):	1


Version-Release number of selected component (if applicable):


How reproducible:
Set up FC25 on a Dell Precision 7510 and update to 4.9.3. Did that twice now.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 robert.gartler 2017-01-17 08:15:11 UTC
It looks like opensuse tumbleweed with 4.9.0 has the same problem. Maybe the bug was introduced in 4.9

Comment 2 robert.gartler 2017-01-25 13:12:31 UTC
Problem still exists in 4.9.5

Comment 3 Justin M. Forbes 2017-04-11 14:40:00 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 4 Justin M. Forbes 2017-04-28 17:11:16 UTC
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 2 weeks. If you are still experiencing this issue, please reopen and attach the 
relevant data from the latest kernel you are running and any data that might have been requested previously.


Note You need to log in before you can comment on or make changes to this bug.