Bug 1413777 - Unable to create repositories when a Product has a disabled sync plan
Summary: Unable to create repositories when a Product has a disabled sync plan
Keywords:
Status: CLOSED DUPLICATE of bug 1410939
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Sync Plans
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 23:43 UTC by Mike McCune
Modified: 2017-01-16 23:47 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 23:47:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mike McCune 2017-01-16 23:43:38 UTC
1) Create a product with no repos

2) Create a syncplan, set Sync Enabled to false (uncheck the box)

3) Try to create a Docker repository in Product from step (1)

Note error:


2017-01-16 18:37:55 [foreman-tasks/action] [E] undefined method `iso8601' for nil:NilClass (NoMethodError)
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.90/app/models/katello/sync_plan.rb:57:in `schedule_format'

it creates parts of the repo in the database, but not entirely and user is unable to proceed

Comment 2 Mike McCune 2017-01-16 23:47:38 UTC

*** This bug has been marked as a duplicate of bug 1410939 ***


Note You need to log in before you can comment on or make changes to this bug.