Bug 1413779 - dhcp_domain in "/etc/nova/nova.conf" and "/etc/neutron/dhcp_agent.ini" should match FQDN domain in undercloud.conf
Summary: dhcp_domain in "/etc/nova/nova.conf" and "/etc/neutron/dhcp_agent.ini" should...
Keywords:
Status: CLOSED DUPLICATE of bug 1532376
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 10.0 (Newton)
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 23:47 UTC by Nick Satsia
Modified: 2018-02-28 16:16 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-28 16:16:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
"journalctl -u os-collect-config" from Controller0 (61.12 KB, application/x-gzip)
2017-01-16 23:47 UTC, Nick Satsia
no flags Details

Description Nick Satsia 2017-01-16 23:47:50 UTC
Created attachment 1241471 [details]
"journalctl -u os-collect-config" from Controller0

Description of problem:
I set a FQDN name for undercloud in undercloud.conf but this does not update dhcp_domain in "/etc/nova/nova.conf" and "/etc/neutron/dhcp_agent.ini" (where they default to "localdomain") when I install the undercloud.

When you set the "CloudDomain" (normally same domain as in the undercloud FQDN)  in your overcloud parameters (required for SSL/TLS) it fails the deployment at or just after Step2.2 where MySQL/Galerra fails to start with cannot open socket.

      ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock'

Version-Release number of selected component (if applicable):
RHOSP10d

How reproducible:


Steps to Reproduce:
1. Deploy undercloud
2. Configure overcloud with SSL and set "CloudDomain"
3. Deploy overcloud with 3 controllers

Actual results:
Deployment fails at or just after Step2.2 due to MySQL/Galerra failing to start
       ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock'

Expected results:



Additional info:
If you do not set CloudDomain or set it to "localdomain" it works.


Workaround:
    On the undercloud manually update dhcp_domain in "/etc/nova/nova.conf" and "/etc/neutron/dhcp_agent.ini".

Comment 1 Alex Schultz 2017-03-24 19:03:42 UTC
You might need to set the CloudName* options when you deploy. For example:

[stack@instack ~]$ cat /home/stack/templates/domain.yaml
parameter_defaults:
  CloudDomain: test.example.com
  CloudName: overcloud.test.example.com
  CloudNameInternal: overcloud.internalapi.test.example.com
  CloudNameStorage: overcloud.storage.test.example.com
  CloudNameStorageManagement: overcloud.storagemgmt.test.example.com
  CloudNameCtlplane: overcloud.ctlplane.text.example.com

Comment 2 Nick Satsia 2017-03-29 21:04:45 UTC
(In reply to Alex Schultz from comment #1)
> You might need to set the CloudName* options when you deploy. For example:
> 
> [stack@instack ~]$ cat /home/stack/templates/domain.yaml
> parameter_defaults:
>   CloudDomain: test.example.com
>   CloudName: overcloud.test.example.com
>   CloudNameInternal: overcloud.internalapi.test.example.com
>   CloudNameStorage: overcloud.storage.test.example.com
>   CloudNameStorageManagement: overcloud.storagemgmt.test.example.com
>   CloudNameCtlplane: overcloud.ctlplane.text.example.com

I do set them as needed by enabling TLS/SSL. The is issue is the DHCP server on the director not giving the client a domain as it has an empty domain set, resulting in MySQL/Galerra failing to start:
     "ERROR 2002 (HY000): Can't connect to local MySQL server through socket..."

Comment 3 Thiago Munck 2017-09-20 22:16:25 UTC
We faced the same issue running OSP10 and RHEL7.3. If only setting CloudDomain parameter, MySQL/Galera fails to start on controllers during deploy.

Just removed CloudDomain option from YAML files and performed a new deploy to get things working again.

We'll try the suggested workaround soon.

Thanks.

Comment 4 Alex Schultz 2018-02-28 16:16:16 UTC

*** This bug has been marked as a duplicate of bug 1532376 ***


Note You need to log in before you can comment on or make changes to this bug.