Bug 1413781 - Rebase ipxe for RHEL-7.4
Summary: Rebase ipxe for RHEL-7.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipxe
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: FuXiangChun
URL:
Whiteboard:
Depends On:
Blocks: 1395265
TreeView+ depends on / blocked
 
Reported: 2017-01-16 23:51 UTC by Jeff Nelson
Modified: 2017-08-01 22:31 UTC (History)
14 users (show)

Fixed In Version: ipxe-20170123-1.git4e85b27.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:31:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2075 0 normal SHIPPED_LIVE ipxe bug fix update 2017-08-01 19:35:30 UTC

Description Jeff Nelson 2017-01-16 23:51:45 UTC
Description of problem:

Various components related to qemu-kvm-rhev need to be rebased for RHEL-7.4. It is not known if ipxe is one of them, so this is just a default placeholder in case it's needed.

Note this is would only be needed for the roms-qemu subcomponent, but due to the nature of the rebase action, all ipxe subcomponents would be affected.

Comment 2 Ladi Prosek 2017-01-22 16:16:56 UTC
The following virtio fixes have just been applied to upstream iPXE:

http://git.ipxe.org/ipxe.git/commitdiff/e45451c
http://git.ipxe.org/ipxe.git/commitdiff/b782a56
http://git.ipxe.org/ipxe.git/commitdiff/fba3b39

We want them in 7.4, either through a rebase or cherry-picked individually.


Other commits of interest since the last rebase are Laszlo's:

http://git.ipxe.org/ipxe.git/commitdiff/dd9a14d
http://git.ipxe.org/ipxe.git/commitdiff/b991c67

although I'm not sure if the fxsave/fxrstor bug will be fixed in KVM instead. Adding Laszlo.

Comment 3 Laszlo Ersek 2017-01-23 09:37:09 UTC
The KVM issue / feature request is tracked in RHBZ 1356762.

Comment 10 FuXiangChun 2017-06-01 07:47:01 UTC
Verified bug with ipxe-roms-qemu-20170123-1.git4e85b27.el7.noarch


QE executed a ipxe test run to verify this bug. And no found block  or regression bug.

https://polarion.engineering.redhat.com/polarion/#/project/RedHatEnterpriseLinux7/testrun?id=viirtkvmqe-x86-ipxe

Comment 11 errata-xmlrpc 2017-08-01 22:31:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2075


Note You need to log in before you can comment on or make changes to this bug.