Bug 1413783 - RHEL4 installation hangs on OpenStack instances, due to RHEL4 not obeying DHCP option 26 for MTU
Summary: RHEL4 installation hangs on OpenStack instances, due to RHEL4 not obeying DHC...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general   
(Show other bugs)
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 24.0
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 00:01 UTC by Dan Callaghan
Modified: 2017-02-09 09:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-09 09:16:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Callaghan 2017-01-17 00:01:11 UTC
Description of problem:
Similar problem to what we hit with ipxe, which also doesn't (didn't) obey option 26. The installation starts but then times out fetching the kickstart because the inbound packets dropped, due to having a TCP MSS greater than the MTU of the virtual network (1400 in our case).

Version-Release number of selected component (if applicable):
unreleased develop 608161a (24.0 candidate)

How reproducible:
easily

Steps to Reproduce:
1. configure OpenStack integration on your account
2. run a RHEL4 recipe

Actual results:
Beaker creates an OpenStack instance and runs the RHEL4 installer on there. But it will hit EWD with Anaconda prompting for a language (that means it didn't fetch the kickstart).

Expected results:
should work

Additional info:
RHEL4 dhcp client does not request option 26 nor honour it when sent. MTU always defaults to 1500. Can't change RHEL4 now so we will just need to exclude it from OpenStack.

Comment 1 Dan Callaghan 2017-01-18 03:21:22 UTC
https://gerrit.beaker-project.org/5592

Comment 2 Dan Callaghan 2017-02-09 09:16:52 UTC
This was actually included with Beaker 24.0.


Note You need to log in before you can comment on or make changes to this bug.