Bug 1413807 - Headers in forwarded message credits in opposite order
Summary: Headers in forwarded message credits in opposite order
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 01:29 UTC by Harshula Jayasuriya
Modified: 2017-01-19 05:56 UTC (History)
4 users (show)

Fixed In Version: evolution-3.22.4-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-19 05:56:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Harshula Jayasuriya 2017-01-17 01:29:09 UTC
Description of problem:

a) Forwarding any email inverts the order of the email header to:

-------- Forwarded Message --------

Date: Sun, 09 Oct 2016 13:07:55 +0000
Subject: [Bug 1375645] Evolution is inserting Non-breaking space
instead of Space at the start of lines even with  "Preformatted" set
To: harshula@redhat.com
From: bugzilla@redhat.com
https://bugzilla.redhat.com/show_bug.cgi?id=1375645

b) There's no space/separation between the email header and the email content.


Version-Release number of selected component (if applicable):

* Fedora 25
* evolution-3.22.3-2.fc25.x86_64

How reproducible:

* Always

Steps to Reproduce:
1. Pick an email and press forward.

Actual results:

Date: Sun, 09 Oct 2016 13:07:55 +0000
Subject: [Bug 1375645] Evolution is inserting Non-breaking space
instead of Space at the start of lines even with  "Preformatted" set
To: harshula@redhat.com
From: bugzilla@redhat.com

Expected results:

From: bugzilla@redhat.com
To: harshula@redhat.com
Subject: [Bug 1375645] Evolution is inserting Non-breaking space
instead of Space at the start of lines even with  "Preformatted" set
Date: Sun, 09 Oct 2016 13:07:55 +0000

Comment 1 Milan Crha 2017-01-17 09:37:32 UTC
Thanks for a bug report. I found out that this had been caused by this commit:
https://git.gnome.org/browse/evolution/commit/?id=adcbacd46ee1367cb962acc45fa3b
Pity you didn't report it before yesterday, when the 3.22.4 had been released.

Comment 2 Fedora Update System 2017-01-17 14:17:02 UTC
evolution-3.22.4-2.fc25 evolution-data-server-3.22.4-1.fc25 evolution-ews-3.22.4-1.fc25 evolution-mapi-3.22.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-cfe72f11b6

Comment 3 Fedora Update System 2017-01-17 21:50:03 UTC
evolution-3.22.4-2.fc25, evolution-data-server-3.22.4-1.fc25, evolution-ews-3.22.4-1.fc25, evolution-mapi-3.22.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-cfe72f11b6

Comment 4 Fedora Update System 2017-01-19 05:56:07 UTC
evolution-3.22.4-2.fc25, evolution-data-server-3.22.4-1.fc25, evolution-ews-3.22.4-1.fc25, evolution-mapi-3.22.4-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.