Bug 1413814 - virt-manager and virt-viewer keyboard input not recognized through spice,mouse works fine
Summary: virt-manager and virt-viewer keyboard input not recognized through spice,mous...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk
Version: 7.3
Hardware: Unspecified
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Default Assignee for SPICE Bugs
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 02:27 UTC by 100901017
Modified: 2020-05-29 21:34 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-08 17:36:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 99714 None None None 2017-02-08 17:36:58 UTC

Description 100901017 2017-01-17 02:27:26 UTC
Description of problem:
Hi I created 3VMs on my host server. Using virt-manager and virt-viewer through  a usb keyboard on my host server it works fine with spice.
When I use SSH remotely launch virt-manager and virt-viewer, keyboad input are not registed but mouse works alrite.

Here is the error when I tried use keyboard

(virt-viewer:623): GSpice-CRITICAL **: send_key: assertion 'scancode != 0' failed



Version-Release number of selected component (if applicable):
libvirt-client-2.0.0-10.el7_3.2.x86_64                               
qemu-img-1.5.3-126.el7.x86_64                                      
qemu-kvm-1.5.3-126.el7.x86_64                                     
libvirt-python-2.0.0-2.el7.x86_64                                    
libvirt-2.0.0-10.el7_3.2.x86_64                                      
virt-viewer-2.0-12.el7.x86_64                                        
virt-manager-1.4.0-2.el7.noarch                                   
bridge-utils-1.5-9.el7.x86_64                             
virt-install-1.4.0-2.el7.noarch                        


How reproducible:
constant

Steps to Reproduce:
1.Connect host using SSH
2. virt-manager
3.keyboard stroke not recognised

Actual results:
no thing happens

Expected results:
input chars

Additional info:

Comment 1 Pavel Hrdina 2017-01-19 11:37:38 UTC
So based on this bug 1170509 it doesn't seem to be virt-manager or virt-viewer issue.

What is your system from which you are connecting to the host via SSH? If your system uses Wayland instead of Xorg the bug will be probably in Spice.

I was not able to reproduce it when connecting from system with Xorg, then I've tried Fedora 25 (where Wayland is the default) and I was able to reproduce it.

Comment 2 Pavel Hrdina 2017-02-08 16:57:48 UTC
Based on this bug https://bugzilla.redhat.com/show_bug.cgi?id=1170509 moving to spice-gtk component.

Comment 3 Pavel Grunt 2017-02-08 17:36:59 UTC
thanks for the bug report

if client does not know what keymap is used (can be seen in debug "vnc-keymap-WARNING **: Unknown keycode mapping '(unnamed)'") then no keymap is used...

Anyway I don't think this (ssh from wayland to run a spice client) is supported, it has to be solved upstream first - i opened a bug https://bugs.freedesktop.org/show_bug.cgi?id=99714 for it.


Note You need to log in before you can comment on or make changes to this bug.