Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1413843 - Moving the nodes to maintenance on Console does not have its intended effect on Nagios
Summary: Moving the nodes to maintenance on Console does not have its intended effect ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc-monitoring-uiplugin
Version: rhgs-3.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 06:13 UTC by Sweta Anandpara
Modified: 2018-10-24 06:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-24 06:13:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sweta Anandpara 2017-01-17 06:13:22 UTC
Description of problem:
========================
I had a 4node cluster on Console with 3.1.3 build. Nagios (with mail notification) was also configured on the rhsc-mgmt node. While updating the gluster version from 3.1.3 to 3.2 of the hosts, it is advised to move them to maintenance on Console. After doing so, we would _not_ expect nagios to continue monitoring the hosts. But it does.

This results in receiving unnecessary and innumerable mail notifications stating the poor health of the many services corresponding to every volume and host and cluster. It is not alarming to the admin to receive such mails as one knows that the hosts are undergoing an update, but it is not something that one would have expected, certainly not the _number_ that one actually receives.

RameshN did mention that Console does not interact with Nagios, other than allowing it to display the graphs, and that the intended result can be achieved by explicitly scheduling a downtime (for a particular duration) in Nagios homepage. 

If we choose to live with it (no harm), then it should be documented advising users to do the needful if they choose to do so.

Version-Release number of selected componenont (if applicable):
================================================================
[root@dhcp35-51 ~]# rpm -qa |grep rhsc
rhsc-log-collector-3.1.0-1.0.el6rhs.noarch
rhsc-branding-rhs-3.1.2-0.el6rhs.noarch
rhsc-setup-plugin-ovirt-engine-3.1.3-0.73.el6.noarch
rhsc-setup-plugins-3.1.3-1.el6rhs.noarch
rhsc-extensions-api-impl-3.1.3-0.73.el6.noarch
redhat-access-plugin-rhsc-3.1.3-0.el6.noarch
rhsc-cli-3.0.0.0-0.2.el6rhs.noarch
rhsc-setup-plugin-ovirt-engine-common-3.1.3-0.73.el6.noarch
rhsc-webadmin-portal-3.1.3-0.73.el6.noarch
rhsc-tools-3.1.3-0.73.el6.noarch
rhsc-sdk-python-3.0.0.0-0.2.el6rhs.noarch
rhsc-monitoring-uiplugin-0.2.4-1.el6rhs.noarch
rhsc-setup-base-3.1.3-0.73.el6.noarch
rhsc-dbscripts-3.1.3-0.73.el6.noarch
rhsc-backend-3.1.3-0.73.el6.noarch
rhsc-doc-3.1.2-0.el6eng.noarch
rhsc-restapi-3.1.3-0.73.el6.noarch
rhsc-3.1.3-0.73.el6.noarch
rhsc-lib-3.1.3-0.73.el6.noarch
rhsc-setup-3.1.3-0.73.el6.noarch
[root@dhcp35-51 ~]# 
[root@dhcp35-51 ~]# rpm -qa | grep nagios
pnp4nagios-0.6.22-2.1.el6rhs.x86_64
nagios-plugins-1.4.16-12.el6rhs.x86_64
nagios-plugins-nrpe-2.15-4.2.el6rhs.x86_64
gluster-nagios-common-0.2.4-1.el6rhs.noarch
nagios-server-addons-0.2.5-1.el6rhs.noarch
nagios-plugins-ping-1.4.16-12.el6rhs.x86_64
nagios-3.5.1-6.el6.x86_64
nagios-common-3.5.1-6.el6.x86_64
nagios-plugins-dummy-1.4.16-12.el6rhs.x86_64
[root@dhcp35-51 ~]# 


How reproducible:
=================
Always

Comment 2 Sahina Bose 2017-01-17 06:19:57 UTC
RHGS-C and Nagios are not very tightly integrated beyond the configuration during addition of hosts and displaying Nagios graphs in Trends tab.

Moving host to maintenance in RHGS-C has no effect on Nagios - this request is a much broader enhancement of tighter integration.

Comment 7 Sahina Bose 2018-10-24 06:13:42 UTC
Closing as there's no further enhancements planned on RHGS-C


Note You need to log in before you can comment on or make changes to this bug.