Bug 1413858 - Copy and paste when on wayland with gedit stops working
Summary: Copy and paste when on wayland with gedit stops working
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: wayland-protocols
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 07:37 UTC by Daniel Rowe
Modified: 2017-09-21 08:08 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-16 08:34:45 UTC


Attachments (Terms of Use)

Description Daniel Rowe 2017-01-17 07:37:09 UTC
Description of problem:

Copy and paste when on wayland with gedit stops working some of the time.

I have noticed this when copying text out of gedit and into other apps.

It works then it stops, i.e. you copy a block of text and try a paste it into a different app and the buffer is empty, nothing copies.

Save, exit gedit reopen and it works again for a while.

I have noticed it doing this with gedit to firefox and gedit to LibreOffice Writer.

When this happens and I tey and paste into LibreOffice Writer, writer just get a busy spinner but not text is copied.

Version-Release number of selected component (if applicable):

libinput.x86_64 1.5.901-1.fc25
gedit.x86_64 2:3.22.0-2.fc25
libwayland-client.x86_64 1.12.0-1.fc25
libwayland-server.x86_64 1.12.0-1.fc25

How reproducible:

Some of the time, if you are doing a lots of copy and paste then I inevitably hit this issue.

Steps to Reproduce:
1. Open body of text
2. Copy text but selecting with mouse and right click and select copy
3. Paste into a different app, probably also work with a different gedit window
4. Will stop working at random times requiring an exit of edit to fix.

Actual results:

Cant copy text and paste it

Expected results:

Can copy text and paste it 

Additional info:

Comment 1 Daniel Rowe 2017-01-17 07:41:08 UTC
Maybe issue with wayland native app to X11 app? As when this happens I can still copy and paste in gedit itself and another gedit window.

Comment 2 Fabio Alessandro Locati 2017-01-20 11:58:42 UTC
See https://github.com/SirCmpwn/sway/issues/1012

Comment 3 Daniel Rowe 2017-01-22 10:24:05 UTC
Just noticed this in the logs:

gedit[2089]: Error writing selection data: Error writing to file descriptor: Broken pipe

Comment 4 Anass Ahmed 2017-02-21 14:37:23 UTC
I've this issue with LibreOffice Write, GEdit, Geary (a lot of times when I copy from Geary, it doesn't work!!).

I use GPaste shell extension too, (sometimes selecting the copied text from it solve the issue).

Comment 5 Anass Ahmed 2017-02-21 14:39:05 UTC
I also have the same message as Daniel:

(soffice:351): Gdk-WARNING **: Error writing selection data: Error writing to file descriptor: Broken pipe

I use LibreOffice GTK3 on Wayland.

Comment 6 morphey 2017-03-01 10:00:02 UTC
I have the same problem:

mar 01 10:56:43 morphey.morphey gedit[3592]: Error writing selection data: Errore nello scrivere sul descrittore di file: Broken pipe
mar 01 10:56:43 morphey.morphey gedit[3592]: Error writing selection data: Errore nello scrivere sul descrittore di file: Broken pipe

Comment 7 Lorenzo Dalrio 2017-03-17 09:39:08 UTC
Same here, both gedit and evolution show the problem.

Comment 8 James Stocker 2017-03-23 16:25:17 UTC
Argh this bug is infuriating!

I've so far ditched copyq because of this behaviour, then ditched parcellite and moved on to gpaste, all of which have the same issue. I can't copy from gedit and paste in to gnome terminal, or firefox. But copying something in gedit I can still paste it back in to gedit even though the clipboard manager doesn't list anything in the clipboard. restarting gedit fixes the issue for a while.

Comment 9 Lorenzo Dalrio 2017-05-10 14:41:28 UTC
This is happening on evolution too:

May 10 16:35:49 gollum evolution[5719]: Error writing selection data: Error writing to file descriptor: Broken pipe

Comment 10 Igor Gnatenko 2017-05-16 08:32:38 UTC
Pleaase, report this bug in upstream.

Comment 11 Pavlo Rudyi 2017-05-16 08:32:39 UTC
The same on F27 with firefox and gnome-terminal.

Comment 12 James Stocker 2017-05-16 08:35:51 UTC
(In reply to Igor Gnatenko from comment #10)
> Pleaase, report this bug in upstream.

Report it to who, where to report it?

Comment 13 Daniel Rowe 2017-05-16 09:08:48 UTC
Copy and paste when on wayland on Fedora is fundamentally​ broken IMHO. It not just gedit. Seem to be when working between native Wayland and X apps.

Wayland is a poster feature of Fedora and problems should be posted here I think.

Don't get me wrong Wayland has been mostly positive for me.

I'll definitely be raising a bug with freedesktop.

Comment 14 James Stocker 2017-05-16 10:22:33 UTC
(In reply to Daniel Rowe from comment #13)
> Copy and paste when on wayland on Fedora is fundamentally​ broken IMHO. It
> not just gedit. Seem to be when working between native Wayland and X apps.
> 
> Wayland is a poster feature of Fedora and problems should be posted here I
> think.
> 
> Don't get me wrong Wayland has been mostly positive for me.
> 
> I'll definitely be raising a bug with freedesktop.

Looking at the freedesktop bugzilla I'm not even sure where to raise a bug for this, if you raise one please link us so I can watch

Comment 15 Daniel Rowe 2017-05-16 14:35:03 UTC
https://bugzilla.gnome.org/show_bug.cgi?id=782694

Raised with Gnome bug tracker.

Comment 16 Daniel Rowe 2017-05-16 14:37:35 UTC
(In reply to James Stocker from comment #14)
> (In reply to Daniel Rowe from comment #13)
> > Copy and paste when on wayland on Fedora is fundamentally​ broken IMHO. It
> > not just gedit. Seem to be when working between native Wayland and X apps.
> > 
> > Wayland is a poster feature of Fedora and problems should be posted here I
> > think.
> > 
> > Don't get me wrong Wayland has been mostly positive for me.
> > 
> > I'll definitely be raising a bug with freedesktop.
> 
> Looking at the freedesktop bugzilla I'm not even sure where to raise a bug
> for this, if you raise one please link us so I can watch

Yer sorry not free desktop people. See the bug I have raised. Maybe add to it if you have more info.


Note You need to log in before you can comment on or make changes to this bug.