Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1413868 - Additionally added users/groups to access policies after saving are not saved to the database
Summary: Additionally added users/groups to access policies after saving are not saved...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Beaker
Classification: Retired
Component: web UI
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 08:04 UTC by wangdong
Modified: 2020-06-02 11:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-02 11:44:51 UTC


Attachments (Terms of Use)

Description wangdong 2017-01-17 08:04:26 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. In this page https://beaker-devel.app.eng.bos.redhat.com/view/dev-kvm-guest-01.rhts.eng.bos.redhat.com#access-policy
2. Add 1 valid group
3. Add 1 non-existent group
4. Choose some 
5. Click Save changes

Actual results:
No error report during these action.
For group section, here're some logs capture from server-debug.log

Jan 17 07:27:44 beaker-devel.app.eng.bos.redhat.com beaker-server[3082]: bkr.server.model.activity DEBUG Tentative SystemActivity: object_id=14L, service=u'HTTP', field=u'Access Policy Rule', action=u'Added', old=None, new='<grant view to dowang-test-displayname>', user=dowang
Jan 17 07:27:44 beaker-devel.app.eng.bos.redhat.com beaker-server[3082]: bkr.server.model.activity DEBUG Tentative SystemActivity: object_id=14L, service=u'HTTP', field=u'Access Policy Rule', action=u'Added', old=None, new='<grant view to abcd-list>', user=dowang
Jan 17 07:27:44 beaker-devel.app.eng.bos.redhat.com beaker-server[3082]: bkr.server.wsgi DEBUG Rolling back for 400 response

It's not real add access policy.

Expected results:
Like only add a non-existent group or user, give some error message.

Additional info:
I think it would be better when user want to add a non-existent user/group, the '+Add' button should not clickable.

Comment 1 wangdong 2017-01-17 08:05:27 UTC
Same steps for add non-existent user.

Comment 4 Roman Joost 2017-01-18 06:11:20 UTC
I can reproduce it now. The good thing is that the invalid user/group is not saved in the backend if the user adds another user/group straight after saving and without a reload of the view. The bad thing is, that valid user/group entries are also not saved :(

Comment 5 wangdong 2017-01-19 08:23:02 UTC
(In reply to Roman Joost from comment #4)
> I can reproduce it now. The good thing is that the invalid user/group is not
> saved in the backend if the user adds another user/group straight after
> saving and without a reload of the view. The bad thing is, that valid
> user/group entries are also not saved :(

Can we just allow user add valid user/group. Because that textbox can list valid value.

Comment 6 Tomas Klohna 🔧 2019-04-17 13:18:21 UTC
Issue still applies. Valid entries are not removed as Roman says but there really is no error message for invalid entries if you don't refresh the page.

Comment 7 Martin Styk 2020-06-02 11:44:51 UTC
Hello,

thank you for opening issue in Beaker project.
This issue was marked with component "web ui".
As we are not planning to address any further issues in current UI, due to technical stack and not being able to work with Python 3 codebase, I'm closing this issue as WONTFIX.
New UI will be reimplemented within new versions of Beaker.

If you have any questions feel free to reach out to me.

Best regards,
Martin <martin.styk@redhat.com>


Note You need to log in before you can comment on or make changes to this bug.