Bug 1413888 - radeonsi GL_ARB_tessellation_shader regressed to broken
Summary: radeonsi GL_ARB_tessellation_shader regressed to broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 09:09 UTC by Edward O'Callaghan
Modified: 2017-01-29 00:20 UTC (History)
9 users (show)

Fixed In Version: mesa-13.0.3-4.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-29 00:20:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Edward O'Callaghan 2017-01-17 09:09:43 UTC
The GL_ARB_tessellation_shader (OpenGL 4 and above) is now broken on Fedora 25 with radeonsi because mesa was rebased to 13.x that is using the newer llvm api.

"unsupported calls to llvm.amdgcn.s.waitcnt".



mesa commits using the op are 2c9d26a3  and  836cab51c

$ git grep 'llvm.amdgcn.s.waitcnt'

src/amd/common/ac_nir_to_llvm.c: 

  ac_emit_llvm_intrinsic(&ctx->ac,"llvm.amdgcn.s.waitcnt",

src/gallium/drivers/radeonsi/si_shader.c:

  lp_build_intrinsic(builder, "llvm.amdgcn.s.waitcnt",



Tested with a RX480 using kern 4.9 and mesa 13.0.3

Comment 1 Edward O'Callaghan 2017-01-17 09:18:15 UTC
The 'Unigine Heaven' demo will exercise the behavior to reproduce, scene miss-renders and FPS drop to 2-3fps.

Comment 3 Edward O'Callaghan 2017-01-23 12:26:20 UTC
The following patch is required,

https://cgit.freedesktop.org/mesa/mesa/commit/?id=57f18623fb94891c04f3a395cfd977ea3747ee61

Comment 4 Fedora Update System 2017-01-24 04:19:33 UTC
mesa-13.0.3-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9c9c0899f9

Comment 5 Fedora Update System 2017-01-28 19:19:29 UTC
mesa-13.0.3-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9c9c0899f9

Comment 6 Fedora Update System 2017-01-29 00:20:55 UTC
mesa-13.0.3-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.