Bug 1413925 - Kernel 4.9.3-200 does not work with AMD GPU (Radeon R9 380), 4.8.x worked fine
Summary: Kernel 4.9.3-200 does not work with AMD GPU (Radeon R9 380), 4.8.x worked fine
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 10:30 UTC by Bruno Antunes
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 14:37:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Bruno Antunes 2017-01-17 10:30:05 UTC
Description of problem:

I've updated from 4.8.16-300 to 4.9.3-200 and my GPU stopped working.

Version-Release number of selected component (if applicable):

4.9.3-200

How reproducible:

Always

Steps to Reproduce:
1. Boot
2. Select kernel 4.9.3-200 from Grub menu

Actual results:

Blank screen

Expected results:

Hard drive crypto unlock screen to show up

Additional info:

lspci output for my GPU:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tonga PRO [Radeon R9 285/380] (rev f1)

Comment 1 Laura Abbott 2017-01-17 16:47:19 UTC
Moving this for the graphics team to take a look

Comment 2 Laura Abbott 2017-01-17 21:42:04 UTC
https://koji.fedoraproject.org/koji/taskinfo?taskID=17314239 I pulled in a couple of 'low hanging' ATI graphics fixes to this build, can you please test this? This update will also be available in bodhi.

Comment 3 Bruno Antunes 2017-01-17 22:57:23 UTC
Just tried it, exactly the same as 4.9.3 :|

Comment 4 Bruno Antunes 2017-01-24 14:37:31 UTC
Fixed with kernel 4.9.5-200


Note You need to log in before you can comment on or make changes to this bug.