Bug 1413947 - x200 tablet wacom can no longer be rotated or calibrated
Summary: x200 tablet wacom can no longer be rotated or calibrated
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-libinput
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 12:14 UTC by Alexandre Oliva
Modified: 2017-12-12 10:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 10:53:49 UTC
Type: Bug


Attachments (Terms of Use)
Xorg file showing failure to load wacom driver (32.43 KB, text/plain)
2017-01-24 20:12 UTC, sdh4
no flags Details
Xorg logs while running f24 (xsetwacom and calibration work) (28.50 KB, text/plain)
2017-01-30 02:42 UTC, Alexandre Oliva
no flags Details
Xorg logs while running f25 (xsetwacom and calibration do NOT work) (34.89 KB, text/plain)
2017-01-30 02:44 UTC, Alexandre Oliva
no flags Details

Description Alexandre Oliva 2017-01-17 12:14:34 UTC
Description of problem:
After upgrading from a F24-ish system to a F25-ish one, the wacom tablet built into a thinkpad x200t can no longer be rotated or calibrated.  xsetwacom --list devices does not list any device any more, and diffs in the X11 logs suggest libinput has taken over some of these devices.  xinput names both the pen and the eraser, but that doesn't seem to be enough for such essential functionality as rotation to be exposed through xsetwacom.

Version-Release number of selected component (if applicable):
xorg-x11-drv-wacom-0.34.0-1.fc25.x86_64
xorg-x11-drv-libinput-0.23.0-2.fc25.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1.xinput
2.xsetwacom --list devices
3.xsetwacom --set "<device name>" rotate cw
4.Start wacom calibration in the settings panel

Actual results:
1.The devices are listed (as expected)
2.No devices are listed
3.Rotation does not seem to be possible any more
4.The wacom settings panel says there isn't any wacom tablet connected to the system

Expected results:
1.The devices are listed
2.Ditto
3.I suppose there might be some xinput command that would accomplish rotation, but it would be nice if xsetwacom's simple command would still work, even if using a different underlying interface
4.Calibration and other settings

Additional info:

Comment 1 Peter Hutterer 2017-01-17 22:51:38 UTC
xsetwacom is a tool that only works with the xorg-x11-drv-wacom driver, see https://who-t.blogspot.com.au/2016/12/the-future-of-xinput-xmodmap-setxkbmap.html

rotation for the device can still be applied manually by adjusting the matrix, see e.g.:
https://wiki.archlinux.org/index.php/Calibrating_Touchscreen

GNOME hasn't been updated yet to work with libinput for tablets, so I guess the easiest solution would be to make sure the xorg-x11-drv-wacom driver is available and assigned to the input device. Not sure why it isn't, wacom sorts higher than libinput and should take over any matching devices when installed. Please attach your Xorg.log, that should help determine what's going on.

Comment 2 sdh4 2017-01-24 20:12:16 UTC
Created attachment 1244074 [details]
Xorg file showing failure to load wacom driver

Comment 3 sdh4 2017-01-24 20:17:36 UTC
I am running into this problem also, needing to adjust the sensitivity threshold. Just attached an Xorg log 

(with the latest updates logging seems to be broken -- no Xorg.0.log or results from journalctl. This log file was generated by manually running Xorg from a terminal)

The original Fedora 25 worked fine. With the latest updates the wacom device is not seen by xsetwacom. The Wacom device works fine; it's just not adjustable. Bus 001 Device 004: ID 056a:00ec Wacom Co., Ltd TPCEC


xorg-x11-drv-wacom is definitely installed. I tried downgrading to my previously installed version (0.33.99.1-1) but that did not help. 

Any thoughts? 
Thanks!

Comment 4 Alexandre Oliva 2017-01-30 02:42:11 UTC
Created attachment 1245736 [details]
Xorg logs while running f24 (xsetwacom and calibration work)

Comment 5 Alexandre Oliva 2017-01-30 02:44:00 UTC
Created attachment 1245737 [details]
Xorg logs while running f25 (xsetwacom and calibration do NOT work)

Comment 6 Fedora End Of Life 2017-11-16 19:49:35 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 7 Peter Hutterer 2017-11-17 00:54:25 UTC
sorry, that fell through.

From attachment 1245737 [details]:
[    94.810] (II) Using input driver 'evdev' for 'Wacom Serial Penabled 1FG Touchscreen Finger'
and the same message for the Pen device.

For serial tablets we ship a systemd service file that uses inputattach to create a proper event node. You then need to use the wacom driver for that node if you want it to work as before. 

The problem is in this line:
[   138.152] (**) Wacom Serial Penabled 1FG Touchscreen Pen: Applying InputClass "evdev tablet catchall"

for some reason the evdev driver overrides the other drivers. My guess is you have cinnamon or mate, or had them installed at some point so now your xorg.conf is screwed up. Check /etc/X11/xorg.conf.d for any mate/cinnamon-related leftover files or links and remove them.

The same appears to be the case for attachment 1244074 [details]

Comment 8 Fedora End Of Life 2017-12-12 10:53:49 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.