Bug 1413997 - Regression: Kubernetes objects have invalid selfLink field
Summary: Regression: Kubernetes objects have invalid selfLink field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kubernetes
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 14:14 UTC by Stef Walter
Modified: 2017-03-08 15:15 UTC (History)
10 users (show)

Fixed In Version: kubernetes-1.5.2-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-23 05:19:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Stef Walter 2017-01-17 14:14:07 UTC
Description of problem:

Kubernetes objects now have invalid selfLink fields in their object data. They are missing a slash.

# kubectl get nodes --output=json | grep selfLink
                "selfLink": "/api/v1/nodes127.0.0.1",
                "selfLink": "/api/v1/nodesa-mynode",
                "selfLink": "/api/v1/nodesb-mynode",
                "selfLink": "/api/v1/nodesc-mynode",
                "selfLink": "/api/v1/nodesd-mynode",
# kubectl get namespaces --output=json | grep selfLink
                "selfLink": "/api/v1/namespacesdefault",
                "selfLink": "/api/v1/namespaceskube-system",

Version-Release number of selected component (if applicable):

kubernetes-1.5.1-1.fc25.x86_64

How reproducible:

Every time.

The selfLink should look like:

"/api/v1/nodes/127.0.0.1"

Additional info:

This breaks Cockpit's Kubernetes admin interface. This regression was detected by the Cockpit integration test suite.

Comment 1 Stef Walter 2017-01-17 14:15:25 UTC
Example of Cockpit integration test failure: https://github.com/cockpit-project/cockpit/pull/5738

Comment 2 Jason Brooks 2017-01-17 16:59:04 UTC
may be related: https://github.com/kubernetes/kubernetes/issues/37622

Comment 3 Jan Chaloupka 2017-01-18 07:55:49 UTC
$ curl http://localhost:8080/api/v1/nodes 2>/dev/null | grep selfLink
    "selfLink": "/api/v1/nodes",
        "selfLink": "/api/v1/nodes127.0.0.1",

Apiserver already returns the invalid link.

Comment 4 Jan Chaloupka 2017-01-18 08:23:40 UTC
Confirming the patch in #37622 fixes the issue.

Comment 5 Fedora Update System 2017-01-18 11:15:53 UTC
kubernetes-1.5.2-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-74d98bce50

Comment 6 Fedora Update System 2017-01-19 09:11:18 UTC
kubernetes-1.5.2-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-74d98bce50

Comment 7 Fedora Update System 2017-01-23 05:19:38 UTC
kubernetes-1.5.2-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Michal Fojtik 2017-03-08 15:15:56 UTC
*** Bug 1430427 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.